www-apps/tt-rss: Bump to new rolling release.
authorThomas Kahle <tomka@gentoo.org>
Thu, 24 Sep 2015 12:23:28 +0000 (14:23 +0200)
committerThomas Kahle <tomka@gentoo.org>
Thu, 24 Sep 2015 12:24:06 +0000 (14:24 +0200)
Package-Manager: portage-2.2.20.1

www-apps/tt-rss/Manifest
www-apps/tt-rss/tt-rss-20150924.ebuild [new file with mode: 0644]

index ce27bc1cacd3f988206c5e6dd9c2418c1eaba789..9f14d15e4fc636170869f34fffbd6e6e205aff45 100644 (file)
@@ -1,2 +1,3 @@
 DIST tt-rss-20150304.tar.bz2 2021676 SHA256 72ec8863c0697a311c3a7b641ade8be4a0e85674aead50bdf03637d76b4eeac3 SHA512 6b26e6a4e0c41bd48efa3506b441adec7ef95c80c208784482e77a382ab4473d152f9ef6436c5e398563c76de634b99a1e1b13efeeb82d30659d4ccf21117ff7 WHIRLPOOL 799c8df18fb5b10c76ce3eb97be77611c0438be7f9b3cd9d4d85cde2d4951c5690b905b3938b574c1810d0ec81d1c246c62769b199a93c72ec0bb4564e56358f
 DIST tt-rss-20150624.tar.bz2 2071177 SHA256 544833ffbdb83497270aa3c3599ad78f58b23bbaf9d492a3b73bd156b806edc7 SHA512 270f88ae84778cf2a5df1dcda2bdc58a0ed8f4988c124728d4aad29324dc86b1b0245c5b651c738febc9447a5533ca68e2655966409a45651c6df3a08e203c1e WHIRLPOOL 8e30b32beb6eba33e6f87c06900804f6f1f3a11ec0ce4c565e7558577f2bea813e082e7d76acb83f0c0aa5a387ef8266f3fc218def482e9508c492e7df5b3b7a
+DIST tt-rss-20150924.tar.bz2 2089704 SHA256 e66521e806014c094181839c9d446fdfbae18a91cfaaaa99fccc9e9f6d27f46d SHA512 b97cf54e4988caac67c5a0985ce7dac9ac2c60f9bedc86d29c83e939082f988cea0de02433b72d9238980e6bb32dea1e10a867ca8cd9ad084f8d7690bf76d3c9 WHIRLPOOL 7add018455697283f11471f3ae967bdb48b447d492972b8a92b77b0f034d6ad297c30c49173233f0b54985837ba51799ad1195a482da86939392e6629b6c89c2
diff --git a/www-apps/tt-rss/tt-rss-20150924.ebuild b/www-apps/tt-rss/tt-rss-20150924.ebuild
new file mode 100644 (file)
index 0000000..a8c5261
--- /dev/null
@@ -0,0 +1,89 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit user eutils webapp vcs-snapshot
+
+DESCRIPTION="Tiny Tiny RSS - A web-based news feed (RSS/Atom) aggregator using AJAX"
+HOMEPAGE="http://tt-rss.org/"
+SRC_URI="https://dev.gentoo.org/~tomka/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="daemon +mysql postgres"
+
+DEPEND="
+       daemon? ( dev-lang/php:*[mysql?,postgres?,pcntl,curl] )
+       !daemon? ( dev-lang/php:*[mysql?,postgres?,curl] )
+       virtual/httpd-php:*
+"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="|| ( mysql postgres )"
+
+need_httpd_cgi  # From webapp.eclass
+
+pkg_setup() {
+       webapp_pkg_setup
+
+       if use daemon; then
+                       enewgroup ttrssd
+                       enewuser ttrssd -1 /bin/sh /dev/null ttrssd
+       fi
+}
+
+src_prepare() {
+       # Customize config.php-dist so that the right 'DB_TYPE' is already set (according to the USE flag)
+       einfo "Customizing config.php-dist..."
+
+       if use mysql && ! use postgres; then
+                       sed -i \
+                               -e "/define('DB_TYPE',/{s:pgsql:mysql:}" \
+                               config.php-dist || die
+       fi
+
+       sed -i \
+               -e "/define('DB_TYPE',/{s:// \(or mysql\):// pgsql \1:}" \
+               config.php-dist || die
+
+       # per 462578
+       epatch_user
+}
+
+src_install() {
+       webapp_src_preinst
+
+       insinto "/${MY_HTDOCSDIR}"
+       doins -r *
+       keepdir "/${MY_HTDOCSDIR}"/feed-icons
+
+       for DIR in cache lock feed-icons; do
+                       webapp_serverowned -R "${MY_HTDOCSDIR}/${DIR}"
+       done
+
+       # In the old days we put a config.php directly and tried to
+       # protect it with the following which did not work reliably.
+       # These days we only install the config.php-dist file.
+       # webapp_configfile "${MY_HTDOCSDIR}"/config.php
+
+       if use daemon; then
+                       webapp_postinst_txt en "${FILESDIR}"/postinstall-en-with-daemon.txt
+                       newinitd "${FILESDIR}"/ttrssd.initd-r2 ttrssd
+                       newconfd "${FILESDIR}"/ttrssd.confd-r1 ttrssd
+                       insinto /etc/logrotate.d/
+                       newins "${FILESDIR}"/ttrssd.logrotated ttrssd
+
+                       elog "After upgrading, please restart ttrssd"
+       else
+                       webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+       fi
+
+       webapp_src_install
+}
+
+pkg_postinst() {
+       elog "You need to merge config.php and config.php-dist manually now."
+       webapp_pkg_postinst
+}