www-servers/tomcat: removed obsolete 8.5.53
authorMiroslav Šulc <fordfrog@gentoo.org>
Thu, 14 May 2020 06:57:46 +0000 (08:57 +0200)
committerMiroslav Šulc <fordfrog@gentoo.org>
Thu, 14 May 2020 07:00:29 +0000 (09:00 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
www-servers/tomcat/Manifest
www-servers/tomcat/tomcat-8.5.53.ebuild [deleted file]

index fe8eabaae4359e1f9dcd1354265cfd2e688b7159..ca5031cf453dc264e74939c65cc80ce7dcdf8621 100644 (file)
@@ -1,5 +1,4 @@
 DIST apache-tomcat-7.0.103-src.tar.gz 5279592 BLAKE2B a8ab36fb84cf158fcd8b888276576cd523d211ab0f6fe0933f600d1990a8f68076f192177a574987e52440037c0ebefd3edaf3c84fee541afb076c5ad33cce9b SHA512 812fce83c7242ebc16dc2365f0b363f1fb2691cd6a2f19f1209ea467557c42ee2d108c8bef89f23bb4a20c800d0ecdb4afc37567ef8079966b4eec0331a2ef9b
-DIST apache-tomcat-8.5.53-src.tar.gz 5676477 BLAKE2B 284ddc3b3d491a57aac31fc59a9c7d80bdb11efb410ab53eea5d3a0a754507203de287eff0a621d02bfea581b45b860598c8ab95d529ad18790fe381f5518cca SHA512 d78613042a9e4caa5b5eeebd2589383ef10312698e535e2c8f82e40c7b3d793ea6cac50f346316a84f4b47ad330f82c7a4f0e4a3d2f0d449f1d4dad9c6d5e267
 DIST apache-tomcat-8.5.54-src.tar.gz 5689648 BLAKE2B 7d4c80cb86261bba46b1879d8f2b9218a63cfb069d32dfe72bd5d73baf87887cdff37c5841c44196ded1dbafcfe2d525cb09d8a15905c24600caf107255416cf SHA512 fe4a82fc58aed0df203abf03367f840d7ac498a3ba317eb2b08826e8ab5e705ea13b99f3af1e17878b2cf96271c5d9ff4e7cecf3b2631e061f1b02988449f9e2
 DIST apache-tomcat-8.5.55-src.tar.gz 5719386 BLAKE2B 4d5d20cf81e0a9aba1fe2b0fc2e9641696a2c7b4bfe1cefd1e86025612484ef06a8171e28722bcde91b671df5bd6e148b22c2fc267828109c6af762fe35f8fdb SHA512 214758bf4dc868c38fd92a19e405f3cd8e47008dee82610f8f7373d92ab5f8800c160a42c96c293f599b702c1c9d2967ca40d3410c1f6a14745edac4739f177d
 DIST apache-tomcat-9.0.34-src.tar.gz 5843244 BLAKE2B e4124c5986b0be26f17cf5e62443fa945ebea6dd713db6a7f96c8e4c7eed7d8e38610763adda928a7099c1574b00e072635576d9d29cc8ae1b98658f0e341acb SHA512 8ac8a916bfe2d3daf679dab9f299bc50f138f3cc9a6e8679a22862d122dea1e5ce3b9101472295398366f5b5d8477097a3cfb536f01136e72ff09d69b2f6c3df
diff --git a/www-servers/tomcat/tomcat-8.5.53.ebuild b/www-servers/tomcat/tomcat-8.5.53.ebuild
deleted file mode 100644 (file)
index 688cb76..0000000
+++ /dev/null
@@ -1,158 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit eutils java-pkg-2 java-ant-2 prefix user
-
-MY_P="apache-${P}-src"
-
-DESCRIPTION="Tomcat Servlet-3.1/JSP-2.3/EL-3.0/WebSocket-1.1/JASPIC-1.1 Container"
-HOMEPAGE="https://tomcat.apache.org/"
-SRC_URI="mirror://apache/${PN}/tomcat-8/v${PV}/src/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="8.5"
-KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="extra-webapps"
-
-RESTRICT="test" # can we run them on a production system?
-
-ECJ_SLOT="4.5"
-SAPI_SLOT="3.1"
-
-COMMON_DEP="dev-java/eclipse-ecj:${ECJ_SLOT}
-       ~dev-java/tomcat-servlet-api-${PV}:${SAPI_SLOT}"
-RDEPEND="${COMMON_DEP}
-       virtual/jre"
-DEPEND="${COMMON_DEP}
-       app-admin/pwgen
-       >=dev-java/ant-core-1.9.13
-       virtual/jdk:1.8
-       test? (
-               >=dev-java/ant-junit-1.9:0
-               dev-java/easymock:3.2
-       )"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
-       java-pkg-2_pkg_setup
-       enewgroup tomcat 265
-       enewuser tomcat 265 -1 /dev/null tomcat
-}
-
-src_prepare() {
-       default
-
-       find -name '*.jar' -type f -delete -print || die
-
-       # Remove bundled servlet-api
-       rm -rv java/javax/{el,servlet} || die
-
-       eapply "${FILESDIR}/${PN}-8.5.47-build.xml.patch"
-
-       # For use of catalina.sh in netbeans
-       sed -i -e "/^# ----- Execute The Requested Command/ a\
-               CLASSPATH=\`java-config --classpath ${PN}-${SLOT}\`" \
-               bin/catalina.sh || die
-
-       java-pkg-2_src_prepare
-}
-
-JAVA_ANT_REWRITE_CLASSPATH="true"
-
-EANT_BUILD_TARGET="deploy"
-EANT_GENTOO_CLASSPATH="eclipse-ecj-${ECJ_SLOT},tomcat-servlet-api-${SAPI_SLOT}"
-EANT_TEST_GENTOO_CLASSPATH="easymock-3.2"
-EANT_GENTOO_CLASSPATH_EXTRA="${S}/output/classes"
-EANT_NEEDS_TOOLS="true"
-EANT_EXTRA_ARGS="-Dversion=${PV}-gentoo -Dversion.number=${PV} -Dcompile.debug=false -Dexecute.validate=false"
-
-# revisions of the scripts
-IM_REV="-r2"
-INIT_REV="-r1"
-
-src_compile() {
-       EANT_GENTOO_CLASSPATH_EXTRA+=":$(java-pkg_getjar --build-only ant-core ant.jar)"
-       java-pkg-2_src_compile
-}
-
-src_test() {
-       java-pkg-2_src_test
-}
-
-src_install() {
-       local dest="/usr/share/${PN}-${SLOT}"
-
-       java-pkg_jarinto "${dest}"/bin
-       java-pkg_dojar output/build/bin/*.jar
-       exeinto "${dest}"/bin
-       doexe output/build/bin/*.sh
-
-       java-pkg_jarinto "${dest}"/lib
-       java-pkg_dojar output/build/lib/*.jar
-
-       dodoc RELEASE-NOTES RUNNING.txt
-       use doc && java-pkg_dojavadoc output/dist/webapps/docs/api
-       use source && java-pkg_dosrc java/*
-
-       ### Webapps ###
-
-       # add missing docBase
-       local apps="host-manager manager"
-       for app in ${apps}; do
-               sed -i -e "s|=\"true\" >|=\"true\" docBase=\"\$\{catalina.home\}/webapps/${app}\" >|" \
-                       output/build/webapps/${app}/META-INF/context.xml || die
-       done
-
-       insinto "${dest}"/webapps
-       doins -r output/build/webapps/{host-manager,manager,ROOT}
-       use extra-webapps && doins -r output/build/webapps/{docs,examples}
-
-       ### Config ###
-
-       # create "logs" directory in $CATALINA_BASE
-       # and set correct perms, see #458890
-       dodir "${dest}"/logs
-       fperms 0750 "${dest}"/logs
-
-       # replace the default pw with a random one, see #92281
-       local randpw="$(pwgen -s -B 15 1)"
-       sed -i -e "s|SHUTDOWN|${randpw}|" output/build/conf/server.xml || die
-
-       # prepend gentoo.classpath to common.loader, see #453212
-       sed -i -e 's/^common\.loader=/\0${gentoo.classpath},/' output/build/conf/catalina.properties || die
-
-       insinto "${dest}"
-       doins -r output/build/conf
-
-       ### rc ###
-
-       cp "${FILESDIR}"/tomcat{.conf,${INIT_REV}.init,-instance-manager${IM_REV}.bash} "${T}" || die
-       eprefixify "${T}"/tomcat{.conf,${INIT_REV}.init,-instance-manager${IM_REV}.bash}
-       sed -i -e "s|@SLOT@|${SLOT}|g" "${T}"/tomcat{.conf,${INIT_REV}.init,-instance-manager${IM_REV}.bash} || die
-
-       insinto "${dest}"/gentoo
-       doins "${T}"/tomcat.conf
-       exeinto "${dest}"/gentoo
-       newexe "${T}"/tomcat${INIT_REV}.init tomcat.init
-       newexe "${T}"/tomcat-instance-manager${IM_REV}.bash tomcat-instance-manager.bash
-}
-
-pkg_postinst() {
-       elog "New ebuilds of Tomcat support running multiple instances. If you used prior version"
-       elog "of Tomcat (<7.0.32), you have to migrate your existing instance to work with new Tomcat."
-       elog "You can find more information at https://wiki.gentoo.org/wiki/Apache_Tomcat"
-
-       elog "To manage Tomcat instances, run:"
-       elog "  ${EPREFIX}/usr/share/${PN}-${SLOT}/gentoo/tomcat-instance-manager.bash --help"
-
-       ewarn "tomcat-dbcp.jar is not built at this time. Please fetch jar"
-       ewarn "from upstream binary if you need it. Gentoo Bug # 144276"
-
-       einfo "Please read https://wiki.gentoo.org/wiki/Apache_Tomcat and"
-       einfo "https://wiki.gentoo.org/wiki/Project:Java/Tomcat_6_Guide for more information."
-}