x11-themes/qtcurve: Fix build with GCC-9
authorAndreas Sturmlechner <asturm@gentoo.org>
Wed, 5 Jun 2019 16:03:50 +0000 (18:03 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 5 Jun 2019 16:08:45 +0000 (18:08 +0200)
Closes: https://bugs.gentoo.org/685794
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
x11-themes/qtcurve/files/qtcurve-1.9.0-gcc9.patch [new file with mode: 0644]
x11-themes/qtcurve/qtcurve-1.9.0.ebuild

diff --git a/x11-themes/qtcurve/files/qtcurve-1.9.0-gcc9.patch b/x11-themes/qtcurve/files/qtcurve-1.9.0-gcc9.patch
new file mode 100644 (file)
index 0000000..56bf30b
--- /dev/null
@@ -0,0 +1,26 @@
+From ee2228ea2f18ac5da9b434ee6089381df815aa94 Mon Sep 17 00:00:00 2001
+From: Yichao Yu <yyc1992@gmail.com>
+Date: Wed, 5 Jun 2019 09:03:40 -0400
+Subject: [utils/gtkprops] Remove unnecessary constexpr, this is not allowed in
+ C++14
+
+BUG: 408286
+---
+ lib/utils/gtkprops.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/utils/gtkprops.h b/lib/utils/gtkprops.h
+index abc0675..e248255 100644
+--- a/lib/utils/gtkprops.h
++++ b/lib/utils/gtkprops.h
+@@ -74,7 +74,7 @@ class GtkWidgetProps {
+         };
+ #define DEF_WIDGET_SIG_CONN_PROPS(name)                                 \
+         struct _SigConn_##name##_ObjGetter {                            \
+-            constexpr inline GObject*                                   \
++            inline GObject*                                             \
+             operator()(SigConn<_SigConn_##name##_ObjGetter> *p) const   \
+             {                                                           \
+                 return (GObject*)qtcContainerOf(p, Props, name)->m_w;   \
+-- 
+cgit v1.1
index 85ce451395d61265a426f9d576536f41624f91ca..428c60441af9f655524be3adca41c0813a287bee 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -71,6 +71,7 @@ DOCS=( AUTHORS ChangeLog.md README.md TODO.md )
 PATCHES=(
        "${FILESDIR}/${PN}-1.9.0-build_testing.patch"
        "${FILESDIR}/${PN}-1.9.0-no-X-buildfix.patch"
+       "${FILESDIR}/${PN}-1.9.0-gcc9.patch"
 )
 
 src_configure() {