app-emacs/wanderlust: Fix error about default-truncate-lines
authorErik Mackdanz <stasibear@gentoo.org>
Sat, 28 Jul 2018 02:22:15 +0000 (21:22 -0500)
committerErik Mackdanz <stasibear@gentoo.org>
Sat, 28 Jul 2018 02:22:15 +0000 (21:22 -0500)
Package-Manager: Portage-2.3.43, Repoman-2.3.10

app-emacs/wanderlust/files/wanderlust-2.15.9_p20130619-default-truncate-lines.patch [new file with mode: 0644]
app-emacs/wanderlust/wanderlust-2.15.9_p20130619.ebuild

diff --git a/app-emacs/wanderlust/files/wanderlust-2.15.9_p20130619-default-truncate-lines.patch b/app-emacs/wanderlust/files/wanderlust-2.15.9_p20130619-default-truncate-lines.patch
new file mode 100644 (file)
index 0000000..d6da446
--- /dev/null
@@ -0,0 +1,17 @@
+--- a/wl/wl-vars.el.orig       2018-07-27 21:05:15.768467090 -0500
++++ b/wl/wl-vars.el    2018-07-27 21:05:45.590468576 -0500
+@@ -1742,12 +1742,12 @@
+   :group 'wl-pref
+   :type 'string)
+-(defcustom wl-message-truncate-lines default-truncate-lines
++(defcustom wl-message-truncate-lines nil
+   "*Truncate lines in Message Buffer."
+   :type 'boolean
+   :group 'wl-pref)
+-(defcustom wl-draft-truncate-lines default-truncate-lines
++(defcustom wl-draft-truncate-lines nil
+   "*Truncate lines in Draft Buffer."
+   :type 'boolean
+   :group 'wl-draft
index 2f035471caadd15a8ea10b447ce03b57a7d6aba6..51d5a4750a4cb248bccb64e8303423fd0fc98e36 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=6
 
 inherit elisp
 
@@ -22,6 +22,7 @@ DEPEND=">=app-emacs/apel-10.6
 RDEPEND="${DEPEND}"
 
 S="${WORKDIR}/${PN}"
+ELISP_PATCHES="${P}-default-truncate-lines.patch"
 SITEFILE="50${PN}-gentoo.el"
 
 src_configure() {