Added missing quotes to allow filenames with spaces. Reported by Quacks in #gentoo...
authorMatthias Schwarzott <zzam@gentoo.org>
Wed, 14 Jun 2006 12:13:24 +0000 (12:13 +0000)
committerMatthias Schwarzott <zzam@gentoo.org>
Wed, 14 Jun 2006 12:13:24 +0000 (12:13 +0000)
Package-Manager: portage-2.1

media-tv/vdr-dvd-scripts/ChangeLog
media-tv/vdr-dvd-scripts/files/0.0.1/dvdchanger_readdvd.sh
media-tv/vdr-dvd-scripts/files/0.0.1/dvdchanger_readdvd_real.sh
media-tv/vdr-dvd-scripts/files/0.0.1/dvdchanger_writedvd.sh
media-tv/vdr-dvd-scripts/files/0.0.1/dvdchanger_writedvd_real.sh
media-tv/vdr-dvd-scripts/files/digest-vdr-dvd-scripts-0.0.1-r5 [new file with mode: 0644]
media-tv/vdr-dvd-scripts/vdr-dvd-scripts-0.0.1-r5.ebuild [new file with mode: 0644]

index 8e38612e2f7c42ccc3917a674e9526e597ec43b9..d3904b1e95955686bc4e4597d35735810d8f0ebe 100644 (file)
@@ -1,6 +1,16 @@
 # ChangeLog for media-tv/vdr-dvd-scripts
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/vdr-dvd-scripts/ChangeLog,v 1.6 2006/05/22 20:58:34 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/vdr-dvd-scripts/ChangeLog,v 1.7 2006/06/14 12:13:24 zzam Exp $
+
+*vdr-dvd-scripts-0.0.1-r5 (14 Jun 2006)
+
+  14 Jun 2006; Matthias Schwarzott <zzam@gentoo.org>
+  files/0.0.1/dvdchanger_readdvd.sh, files/0.0.1/dvdchanger_writedvd.sh,
+  files/0.0.1/dvdchanger_readdvd_real.sh,
+  files/0.0.1/dvdchanger_writedvd_real.sh, -vdr-dvd-scripts-0.0.1-r4.ebuild,
+  +vdr-dvd-scripts-0.0.1-r5.ebuild:
+  Added missing quotes to allow filenames with spaces. Reported by Quacks in
+  #gentoo-vdr.
 
   22 May 2006; Matthias Schwarzott <zzam@gentoo.org>
   vdr-dvd-scripts-0.0.1-r4.ebuild:
index 2300842f238a15fd3ad5b29102342829739201fd..207a41fa9b86d7a9e139921c3495fd4d784031c3 100644 (file)
@@ -2,4 +2,4 @@
 #
 # $1 = filename of the iso file
 
-/usr/lib/vdr/bin/vdr-bg.sh /usr/share/vdr/dvdchanger/dvdchanger_readdvd_real.sh $@
+/usr/lib/vdr/bin/vdr-bg.sh /usr/share/vdr/dvdchanger/dvdchanger_readdvd_real.sh "$@"
index 99f7cd4135b22b72223ce0c9ebf12c5b56d4f7d9..9e790a7d64a1db114ceca0c76ddfcc6caf5ee5b8 100644 (file)
@@ -16,9 +16,9 @@
 # $2 = name of dvd
 # $3 = original dvd-device
 
-rm -f $1/$2
+rm -f "$1/$2"
   
 svdrpsend.pl -d localhost "MESG DVD einlesen gestartet"
-dd if=$3 of=$1/$2
+dd if="$3" of="$1/$2"
 svdrpsend.pl -d localhost "MESG DVD $2 fertig"
 
index 66c009ed15c0b1e5f551994b58ea326c90879511..2b3b534d6cf6a30d8eb9880b8664588b8640bf03 100644 (file)
@@ -2,4 +2,4 @@
 #
 # $1 = filename of the iso file
 
-/usr/lib/vdr/bin/vdr-bg.sh /usr/share/vdr/dvdchanger/dvdchanger_writedvd_real.sh $@
+/usr/lib/vdr/bin/vdr-bg.sh /usr/share/vdr/dvdchanger/dvdchanger_writedvd_real.sh "$@"
index cc35fd0157b0b974ee817ca753daaabae1d23dd4..615a44ed058755b1f499e79cacac0c7f78d8a732 100644 (file)
@@ -1,13 +1,13 @@
 #!/bin/sh
 #
-# $Header: /var/cvsroot/gentoo-x86/media-tv/vdr-dvd-scripts/files/0.0.1/dvdchanger_writedvd_real.sh,v 1.2 2006/04/03 18:46:25 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/vdr-dvd-scripts/files/0.0.1/dvdchanger_writedvd_real.sh,v 1.3 2006/06/14 12:13:24 zzam Exp $
 #
 # 04 Mar 2006; Joerg Bornkessel <hd_brummy@gentoo.org>
 # addaptded to gentoo-vdr-scripts
 
 [[ -e /etc/conf.d/vdr.cd-dvd ]] && source /etc/conf.d/vdr.cd-dvd
 
-ISO_FILE=`echo ${@} | sed 's:\ IMAGE::g'`
+ISO_FILE="${1// IMAGE/}"
 
 #logger -t burnscript burn ${ISO_FILE} --
 
@@ -18,5 +18,5 @@ DVDPLUS_RECORD_OPTS="-use-the-force-luke=tty -dvd-compat -Z"
 
 unset SUDO_COMMAND
 svdrpsend.pl -d localhost "MESG DVD burn initiated"
-$DVD_RECORDCMD $DVDPLUS_RECORD_OPTS $VDR_DVDWRITER="${ISO_FILE}"
+"$DVD_RECORDCMD" $DVDPLUS_RECORD_OPTS "$VDR_DVDWRITER"="${ISO_FILE}"
 svdrpsend.pl -d localhost "MESG DVD burn completed"
diff --git a/media-tv/vdr-dvd-scripts/files/digest-vdr-dvd-scripts-0.0.1-r5 b/media-tv/vdr-dvd-scripts/files/digest-vdr-dvd-scripts-0.0.1-r5
new file mode 100644 (file)
index 0000000..8b13789
--- /dev/null
@@ -0,0 +1 @@
+
diff --git a/media-tv/vdr-dvd-scripts/vdr-dvd-scripts-0.0.1-r5.ebuild b/media-tv/vdr-dvd-scripts/vdr-dvd-scripts-0.0.1-r5.ebuild
new file mode 100644 (file)
index 0000000..fdcd54a
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/vdr-dvd-scripts/vdr-dvd-scripts-0.0.1-r5.ebuild,v 1.1 2006/06/14 12:13:24 zzam Exp $
+
+DESCRIPTION="scripts for vdr-plugins vdrselect and vdrswitch"
+HOMEPAGE="http://www.vdr-wiki.de/wiki/index.php/Dvdselect_readdvd.sh"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+RDEPEND=">=media-tv/gentoo-vdr-scripts-0.3.0-r1"
+
+src_install() {
+       exeinto /usr/share/vdr/dvdchanger
+       exeopts -m0755
+       doexe ${FILESDIR}/${PV}/*.sh
+}