Revert "app-emulation/qemu: conditionally depend on python"
authorMatthias Maier <tamiko@gentoo.org>
Tue, 9 Jul 2019 15:12:13 +0000 (10:12 -0500)
committerMatthias Maier <tamiko@gentoo.org>
Tue, 9 Jul 2019 15:14:05 +0000 (10:14 -0500)
This reverts commit d7d649de1938fc5430174b23631ca7784f875fbc.
in reference to: https://github.com/gentoo/gentoo/pull/12408

Signed-off-by: Matthias Maier <tamiko@gentoo.org>
app-emulation/qemu/qemu-4.0.0-r3.ebuild
app-emulation/qemu/qemu-9999.ebuild

index 17814190338bfb3c95ed35f15754eff5ab7fdae4..bd09a33e9d4685d2475ec83ced3c5d1ca9ddae71 100644 (file)
@@ -49,8 +49,7 @@ IUSE+=" ${use_softmmu_targets} ${use_user_targets}"
 
 # Allow no targets to be built so that people can get a tools-only build.
 # Block USE flag configurations known to not work.
-REQUIRED_USE="
-       python? ( ${PYTHON_REQUIRED_USE} )
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
        qemu_softmmu_targets_arm? ( fdt )
        qemu_softmmu_targets_microblaze? ( fdt )
        qemu_softmmu_targets_mips64el? ( fdt )
@@ -170,12 +169,12 @@ PPC64_FIRMWARE_DEPEND="
 "
 
 BDEPEND="
+       ${PYTHON_DEPS}
        dev-lang/perl
        sys-apps/texinfo
        virtual/pkgconfig
        doc? ( dev-python/sphinx )
        gtk? ( nls? ( sys-devel/gettext ) )
-       python? ( ${PYTHON_DEPS} )
        test? (
                dev-libs/glib[utils]
                sys-devel/bc
@@ -191,8 +190,8 @@ CDEPEND="
        qemu_softmmu_targets_ppc64? ( ${PPC64_FIRMWARE_DEPEND} )
 "
 DEPEND="${CDEPEND}
+       ${PYTHON_DEPS}
        kernel_linux? ( >=sys-kernel/linux-headers-2.6.35 )
-       python? ( ${PYTHON_DEPS} )
        static? (
                ${ALL_DEPEND}
                ${SOFTMMU_TOOLS_DEPEND}
@@ -404,10 +403,10 @@ qemu_src_configure() {
                # are enabled), but it's not really worth the hassle.  Disable it
                # all the time to avoid automatically detecting it. #568856
                --disable-gcrypt
+               --python="${PYTHON}"
                --cc="$(tc-getCC)"
                --cxx="$(tc-getCXX)"
                --host-cc="$(tc-getBUILD_CC)"
-               $(use python && echo "--python=${PYTHON}")
                $(use_enable debug debug-info)
                $(use_enable debug debug-tcg)
                $(use_enable doc docs)
@@ -542,7 +541,7 @@ qemu_src_configure() {
 src_configure() {
        local target
 
-       use python && python_setup
+       python_setup
 
        softmmu_targets= softmmu_bins=()
        user_targets= user_bins=()
index 85985f8a2ecb364ff03ccba21db4f05e3e1a41db..60bf2213431b5a33477578e7e9c051303981efdd 100644 (file)
@@ -49,8 +49,7 @@ IUSE+=" ${use_softmmu_targets} ${use_user_targets}"
 
 # Allow no targets to be built so that people can get a tools-only build.
 # Block USE flag configurations known to not work.
-REQUIRED_USE="
-       python? ( ${PYTHON_REQUIRED_USE} )
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
        qemu_softmmu_targets_arm? ( fdt )
        qemu_softmmu_targets_microblaze? ( fdt )
        qemu_softmmu_targets_mips64el? ( fdt )
@@ -170,12 +169,12 @@ PPC64_FIRMWARE_DEPEND="
 "
 
 BDEPEND="
+       ${PYTHON_DEPS}
        dev-lang/perl
        sys-apps/texinfo
        virtual/pkgconfig
        doc? ( dev-python/sphinx )
        gtk? ( nls? ( sys-devel/gettext ) )
-       python? ( ${PYTHON_DEPS} )
        test? (
                dev-libs/glib[utils]
                sys-devel/bc
@@ -191,8 +190,8 @@ CDEPEND="
        qemu_softmmu_targets_ppc64? ( ${PPC64_FIRMWARE_DEPEND} )
 "
 DEPEND="${CDEPEND}
+       ${PYTHON_DEPS}
        kernel_linux? ( >=sys-kernel/linux-headers-2.6.35 )
-       python? ( ${PYTHON_DEPS} )
        static? (
                ${ALL_DEPEND}
                ${SOFTMMU_TOOLS_DEPEND}
@@ -402,10 +401,10 @@ qemu_src_configure() {
                # are enabled), but it's not really worth the hassle.  Disable it
                # all the time to avoid automatically detecting it. #568856
                --disable-gcrypt
+               --python="${PYTHON}"
                --cc="$(tc-getCC)"
                --cxx="$(tc-getCXX)"
                --host-cc="$(tc-getBUILD_CC)"
-               $(use python && echo "--python=${PYTHON}")
                $(use_enable debug debug-info)
                $(use_enable debug debug-tcg)
                $(use_enable doc docs)
@@ -540,7 +539,7 @@ qemu_src_configure() {
 src_configure() {
        local target
 
-       use python && python_setup
+       python_setup
 
        softmmu_targets= softmmu_bins=()
        user_targets= user_bins=()