app-dicts/myspell-ru: bump to 20180627
authorAlexander Kurakin <kuraga333@mail.ru>
Sat, 19 Oct 2019 10:30:00 +0000 (13:30 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Wed, 6 Nov 2019 07:07:39 +0000 (09:07 +0200)
Signed-off-by: Alexander Kurakin <kuraga333@mail.ru>
Closes: https://bugs.gentoo.org/667146

Based on https://github.com/gentoo/gentoo/pull/9982
Closes: https://github.com/gentoo/gentoo/pull/13344

Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-dicts/myspell-ru/Manifest
app-dicts/myspell-ru/myspell-ru-20180627.ebuild [new file with mode: 0644]

index ae9a8ce25d2e210e7ce9f27961bed94bbe668e6e..2449f3b6e3ee270915c5c5524a22c6515d6c6c4e 100644 (file)
@@ -1 +1,2 @@
 DIST dict_pack_ru-aot-0-4-0.oxt 1509261 BLAKE2B bdda8be3d0a9266285215ffaa4ad8916312c7904266ed34dffc832b4761887d7d316793c5b0863fdb4cf95808b7afaa24914598c1cdd839e3e073f08aee1fab6 SHA512 00e63f5abcfbb2fecd72dc2a2b80dc5ebb4d16aac909b2f63670235edadd0d22a5ed3ae0508bfdb273a85f32ee60df4e84dc620fa1a44f42543848b71a9d1b01
+DIST dict_pack_ru-aot-0-4-3.oxt 1393032 BLAKE2B 8fa0587ae31a155631f799dc7c0214cab0f6c58a059d6948c540061afd7111eee26c18cc638a560928201ff718a638178cebcbd1b7eb17e65b45709217b47332 SHA512 17c0f4d75c397014e3fcb653c8e20d907d9acb2594ba9e43986312d1081f46638a0e3737cb1bf3932d602342f53add26f02efc4edb7e24dd29522aba901f240a
diff --git a/app-dicts/myspell-ru/myspell-ru-20180627.ebuild b/app-dicts/myspell-ru/myspell-ru-20180627.ebuild
new file mode 100644 (file)
index 0000000..e9a9802
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MYSPELL_DICT=( ru_RU.{dic,aff} )
+MYSPELL_HYPH=( hyph_ru_RU.dic )
+MYSPELL_THES=( ru_th_aot.{dat,idx} )
+
+inherit myspell-r2
+
+EXT="extensions"
+DICT="russian-dictionary-pack"
+MY_PN="dict_pack_ru-aot"
+MY_PV="0.4.3"
+
+DESCRIPTION="Russian spellcheck dictionary based on works of AOT group for myspell/hunspell"
+HOMEPAGE="https://extensions.libreoffice.org/extensions/russian-dictionary-pack"
+SRC_URI="https://extensions.libreoffice.org/${EXT}/${DICT}/0-4.3/@@download/file/${MY_PN}-${MY_PV//./-}.oxt"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux"
+
+src_prepare() {
+       default
+       mv russian-aot.dic ru_RU.dic || die
+       mv russian-aot.aff ru_RU.aff || die
+}