media-gfx/hugin: version bump
authorMarkus Meier <maekke@gentoo.org>
Thu, 10 Mar 2016 18:04:58 +0000 (19:04 +0100)
committerMarkus Meier <maekke@gentoo.org>
Thu, 10 Mar 2016 18:05:30 +0000 (19:05 +0100)
Package-Manager: portage-2.2.27

media-gfx/hugin/Manifest
media-gfx/hugin/hugin-2016.0.0_rc1.ebuild [new file with mode: 0644]
media-gfx/hugin/hugin-9999.ebuild

index 34addc46bbf3d44cf48b0c3071c8e44d9d48cdbe..ac2a26710d2632de97a2a6d1ee0c208e5b435d85 100644 (file)
@@ -1 +1,2 @@
 DIST hugin-2015.0.0.tar.bz2 10611519 SHA256 2cd93c110be95d439f9e68653f3738d059a26f5c28973f75475ef59cbaa2cbbd SHA512 bb2acf4dea80d43280778f67594dd1ddb0c2e186bcbaafe460fe47e0bd464ae2191b9b25344245e7267316e602ac2179cc838a0dcecb0d408c2206890a5ab6a2 WHIRLPOOL f9d47da7962a19894f323b85084fc7fda925ed5041188ffb1fbcea09ce7719baa7b26c95c66ec22139d24b683d6b1cba8b821949c166814e435efc5fc0e0a11e
+DIST hugin-2016.0.0_rc1.tar.bz2 10507908 SHA256 1be18902e70d541a8b2d2855cff7ccd8ce5bdc3836a6185a5d94262392b4f533 SHA512 cb3326513153a7ae3471286baba52ff37d10cd75c52c9c7852c097a3760f8c0aeb3643a039ddddf60f13b3aae4b31d782f8f3d17380328fdfee4c6b94953d488 WHIRLPOOL 096f2dda5a6af476052079d9fff398cddf6bda630f921612e086190482d077dd997b195a0f340cf652179c6e340e48141055b2a87ad329b5d06badaef97c5f49
diff --git a/media-gfx/hugin/hugin-2016.0.0_rc1.ebuild b/media-gfx/hugin/hugin-2016.0.0_rc1.ebuild
new file mode 100644 (file)
index 0000000..5d675f1
--- /dev/null
@@ -0,0 +1,86 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit python-single-r1 wxwidgets versionator cmake-utils
+
+DESCRIPTION="GUI for the creation & processing of panoramic images"
+HOMEPAGE="http://hugin.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 SIFT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+LANGS=" ca@valencia ca_ES cs_CZ da de en_GB es eu fi fr hu it ja nl pl pt_BR ro ru sk sv zh_CN zh_TW"
+IUSE="debug lapack python sift $(echo ${LANGS//\ /\ linguas_})"
+
+CDEPEND="
+       !!dev-util/cocom
+       dev-db/sqlite:3
+       >=dev-libs/boost-1.49.0-r1:0=
+       dev-libs/zthread
+       >=media-gfx/enblend-4.0
+       media-gfx/exiv2:=
+       media-libs/freeglut
+       media-libs/glew:=
+       >=media-libs/libpano13-2.9.19_beta1:0=
+       media-libs/libpng:0=
+       media-libs/openexr:=
+       media-libs/tiff:0
+       >=media-libs/vigra-1.9.0[openexr]
+       sci-libs/fftw:=
+       sys-libs/zlib
+       virtual/glu
+       virtual/jpeg:0
+       virtual/opengl
+       x11-libs/wxGTK:3.0=[X,opengl]
+       lapack? ( virtual/blas virtual/lapack )
+       sift? ( media-gfx/autopano-sift-C )"
+RDEPEND="${CDEPEND}
+       media-libs/exiftool"
+DEPEND="${CDEPEND}
+       dev-cpp/tclap
+       sys-devel/gettext
+       virtual/pkgconfig
+       python? ( ${PYTHON_DEPS} >=dev-lang/swig-2.0.4 )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+S=${WORKDIR}/${PN}-$(get_version_component_range 1-3)
+
+pkg_setup() {
+       DOCS="authors.txt README TODO"
+       mycmakeargs=(
+               -DBUILD_HSI=$(usex python ON OFF)
+               -DENABLE_LAPACK=$(usex lapack ON OFF)
+       )
+       use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+       sed \
+               -e 's:-O3::g' \
+               -i src/celeste/CMakeLists.txt || die
+       rm CMakeModules/{FindLAPACK,FindPkgConfig}.cmake || die
+
+       cmake-utils_src_prepare
+}
+
+src_install() {
+       cmake-utils_src_install
+       use python && python_optimize
+
+       for lang in ${LANGS} ; do
+               case ${lang} in
+                       ca@valencia) dir=ca_ES@valencia;;
+                       *) dir=${lang};;
+               esac
+               use linguas_${lang} || rm -r "${D}"/usr/share/locale/${dir}
+       done
+}
index 061cae176d897ad69b48b48b769919415614a78c..50ecf8ae301739b2118b66e8d27285fd98c58cf8 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -25,7 +25,7 @@ IUSE="debug lapack python sift $(echo ${LANGS//\ /\ linguas_})"
 CDEPEND="
        !!dev-util/cocom
        dev-db/sqlite:3
-       >=dev-libs/boost-1.49.0-r1:=
+       >=dev-libs/boost-1.49.0-r1:0=
        dev-libs/zthread
        >=media-gfx/enblend-4.0
        media-gfx/exiv2:=
@@ -38,7 +38,7 @@ CDEPEND="
        >=media-libs/vigra-1.9.0[openexr]
        sci-libs/fftw:=
        sys-libs/zlib
-       virtual/opengl
+       virtual/glu
        virtual/jpeg:0
        virtual/opengl
        x11-libs/wxGTK:3.0=[X,opengl]
@@ -59,8 +59,8 @@ S=${WORKDIR}/${PN}-$(get_version_component_range 1-3)
 pkg_setup() {
        DOCS="authors.txt README TODO"
        mycmakeargs=(
-               $(cmake-utils_use_enable lapack LAPACK)
-               $(cmake-utils_use_build python HSI)
+               -DBUILD_HSI=$(usex python ON OFF)
+               -DENABLE_LAPACK=$(usex lapack ON OFF)
        )
        use python && python-single-r1_pkg_setup
 }