media-libs/libepoxy: Add USE=X and port to EAPI=6.
authorMatt Turner <mattst88@gentoo.org>
Sat, 4 Mar 2017 07:37:13 +0000 (23:37 -0800)
committerMatt Turner <mattst88@gentoo.org>
Sat, 4 Mar 2017 07:49:54 +0000 (23:49 -0800)
Patch by dolphinling.

Bug: https://bugs.gentoo.org/584436

media-libs/libepoxy/libepoxy-9999.ebuild

index a1390b27cae7db8daef8d95386909c94c5540070..8b741660cf30ae4351b65209cb2f4a767b4ed927 100644 (file)
@@ -1,9 +1,7 @@
 # Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
-
-AUTOTOOLS_AUTORECONF=yes
+EAPI=6
 
 EGIT_REPO_URI="git://github.com/anholt/libepoxy.git"
 
@@ -13,7 +11,7 @@ fi
 
 PYTHON_COMPAT=( python{2_7,3_4,3_5} )
 PYTHON_REQ_USE='xml(+)'
-inherit autotools-multilib ${GIT_ECLASS} python-any-r1
+inherit autotools ${GIT_ECLASS} multilib-minimal python-any-r1
 
 DESCRIPTION="Epoxy is a library for handling OpenGL function pointer management for you"
 HOMEPAGE="https://github.com/anholt/libepoxy"
@@ -27,15 +25,26 @@ fi
 
 LICENSE="MIT"
 SLOT="0"
-IUSE="test"
+IUSE="test X"
 
 DEPEND="${PYTHON_DEPS}
        media-libs/mesa[egl,${MULTILIB_USEDEP}]
        x11-misc/util-macros
-       x11-libs/libX11[${MULTILIB_USEDEP}]"
+       X? ( x11-libs/libX11[${MULTILIB_USEDEP}] )"
 RDEPEND=""
 
 src_unpack() {
        default
        [[ $PV = 9999* ]] && git-r3_src_unpack
 }
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+multilib_src_configure() {
+       ECONF_SOURCE=${S} \
+       econf \
+               $(use_enable X glx)
+}