dev-python/python-ceilometerclient: bup
authorMatthew Thode <prometheanfire@gentoo.org>
Wed, 16 Sep 2015 04:32:17 +0000 (23:32 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Wed, 16 Sep 2015 04:32:17 +0000 (23:32 -0500)
Package-Manager: portage-2.2.20.1

dev-python/python-ceilometerclient/Manifest
dev-python/python-ceilometerclient/python-ceilometerclient-1.1.1.ebuild [new file with mode: 0644]

index 289eda672ce81d2fdd94a791c08366d6df7826f4..aeb8f20231abac25f9599a14ae12ba2974584457 100644 (file)
@@ -1 +1,2 @@
 DIST python-ceilometerclient-1.0.10.tar.gz 77469 SHA256 bbe29a6c85af3ec0bcbb7df1863bb3c3c620fa0423c67f25bd089e0ab7b33059 SHA512 23c9419ffb7610965fb0950e2c60d3f78724b23116a457c36b822c986988aee48c2b3d967f179b68769288f425c0a2ca17c25e90a41bdd487122f03ca42962dd WHIRLPOOL 798e0a0d516bf08f8be904fdba462dc2825de728a7bcca1a5e7056b035ddb992751cd9652968c5ec43dd0938b18cbbf387507b45c5f6b5c54181977609c8c54a
+DIST python-ceilometerclient-1.1.1.tar.gz 87597 SHA256 f48e2d9ecef25ab784510fa0b299d0d73aa8f41652abf9f28393a93612416a29 SHA512 ce4768e67c6a5871ec52de433292c6328d387d94860f808f63ab9102f96ba3ca2397116792a5b907d9037290a31c2780149481f1f12581e0a9dd585f4e8d0909 WHIRLPOOL 6ec0fba808036620729e984ce66ae90a9a45a4a1167ad25dc11e2da549406cfea12758e80574a7cbcb0dc56c99138918c834eb57ad486821c050a6812e425e03
diff --git a/dev-python/python-ceilometerclient/python-ceilometerclient-1.1.1.ebuild b/dev-python/python-ceilometerclient/python-ceilometerclient-1.1.1.ebuild
new file mode 100644 (file)
index 0000000..36ef774
--- /dev/null
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="This is a client library for Ceilometer built on the Ceilometer API"
+HOMEPAGE="https://github.com/openstack/python-ceilometerclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+CDEPEND="
+       >=dev-python/pbr-0.8[${PYTHON_USEDEP}]
+       <dev-python/pbr-1.0[${PYTHON_USEDEP}]"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}
+       test? (
+               >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+               >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+               <dev-python/fixtures-1.3.0[${PYTHON_USEDEP}]
+               >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+               <dev-python/mock-1.1.0[${PYTHON_USEDEP}]
+               >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+               <dev-python/oslo-sphinx-2.6.0[${PYTHON_USEDEP}]
+               >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+               >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+               !~dev-python/sphinx-1.2[${PYTHON_USEDEP}]
+               <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+               >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+               >=dev-python/testtools-0.9.36[${PYTHON_USEDEP}]
+               !~dev-python/testtools-1.2.0[${PYTHON_USEDEP}]
+       )"
+RDEPEND="
+       ${CDEPEND}
+       >=dev-python/iso8601-0.1.9[${PYTHON_USEDEP}]
+       >=dev-python/oslo-i18n-1.5.0[${PYTHON_USEDEP}]
+       <dev-python/oslo-i18n-1.6.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-serialization-1.4.0[${PYTHON_USEDEP}]
+       <dev-python/oslo-serialization-1.5.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-utils-1.4.0[${PYTHON_USEDEP}]
+       <dev-python/oslo-utils-1.5.0[${PYTHON_USEDEP}]
+       >=dev-python/prettytable-0.7[${PYTHON_USEDEP}]
+       <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+       >=dev-python/python-keystoneclient-1.2.0[${PYTHON_USEDEP}]
+       <dev-python/python-keystoneclient-1.4.0[${PYTHON_USEDEP}]
+       >=dev-python/requests-2.2.0[${PYTHON_USEDEP}]
+       !~dev-python/requests-2.4.0[${PYTHON_USEDEP}]
+       >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+       >=dev-python/stevedore-1.3.0[${PYTHON_USEDEP}]
+       <dev-python/stevedore-1.4.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+       sed -i '/^hacking/d' test-requirements.txt || die
+       sed -i '/^argparse/d' requirements.txt || die
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       testr init
+       testr run || die "tests failed under python2.7"
+       flake8 ceilometerclient/tests/ || die "run over tests folder by flake8 yielded error"
+}