net-misc/youtube-dl: Old.
authorJeroen Roovers <jer@gentoo.org>
Fri, 19 Aug 2016 01:08:55 +0000 (03:08 +0200)
committerJeroen Roovers <jer@gentoo.org>
Fri, 19 Aug 2016 01:08:55 +0000 (03:08 +0200)
Package-Manager: portage-2.3.0

net-misc/youtube-dl/Manifest
net-misc/youtube-dl/youtube-dl-2016.08.12.ebuild [deleted file]

index ed7dc1e61a7615c840817797dabc333f50d8954a..be7df611e4a9fdfba38b9b0b67b6b85488e5c145 100644 (file)
@@ -1,4 +1,3 @@
 DIST youtube-dl-2016.01.01.tar.gz 1874602 SHA256 732f37c99d71b4239d72d61dd32214b5a5a618671fb0629c8f8deb28209a172c SHA512 fdb022bed426250e5ee1c2bcc1354dd195c0f9793ca479ca8ca4cfe2f71e07ba100b0dbcda2fb9f310308ab130587d06b16a6a86f9036f0d196b317d2e5b5e92 WHIRLPOOL 152e709ba15264c35a89644ea0d4793bb47c82b317e54043ccfff72e40bdf95e42d76605e801233632d3863537a945cfb9ecc2f75245171b8de31b51ce6af801
-DIST youtube-dl-2016.08.12.tar.gz 2318468 SHA256 fb5224b78cee45df9514d96441c4ec9d9934215e504c07fe8c9252285a33ea5e SHA512 2bc1a32fd92df327588f4fdb2a8cadbb1d56349b28b037b85855cb8fcc0eb2277aaad8b8a62c2fb54d5d48bf0dfcb6287d8a31b94b6945e898133f4d05914a08 WHIRLPOOL 914b372624780bc84865e88aca5f8f0f49c5a024ae5828fc97be4a8aa0962dd5340c569cf4ce6bdf6b2d54d3c57cf676bbc71901079fe1321218fa9b9814ed21
 DIST youtube-dl-2016.08.13.tar.gz 2317746 SHA256 b68b00744f5578c3225d1231d4001a39c79b5912a68de2da1c39c648e36dfeba SHA512 5ab1ddfd31c469a9783125b860cc0cfcd9b0e97beabbf5b00cbb6c92e6f29f02ccc0bc6a6c0b2e8be781e1fb8ca379269bc6dfd8fd478815d18dacecd8ee245f WHIRLPOOL d0a0ce0110ba1b8f60580f8823be3597c563bae868088ed5a0d2461d4892d8cdda55e11dcef71e3ce3c6cd89ab0c48f4900d104c36b6e67d53cf981cfa6f8cd6
 DIST youtube-dl-2016.08.19.tar.gz 2329613 SHA256 9094084dceeeea47da3f8a3071c608b81e28f7c1e8c9b3e92da6b55aeeae961f SHA512 db9e6301b28e0904bd1b002e06ae10cbd0ff54907af33f100220e58817ba68728ce28c60620a307228fed9d97e34e53ed25c2b7aad71e92fe1d99fc71d308378 WHIRLPOOL a52048a65359d860c8ab23734ba004558d32f4813e3fd702606c753d23718194923373f984b7d52a2c5cbac116fe9a3c3e5e86c0ca8cb2596db24bb541248046
diff --git a/net-misc/youtube-dl/youtube-dl-2016.08.12.ebuild b/net-misc/youtube-dl/youtube-dl-2016.08.12.ebuild
deleted file mode 100644 (file)
index 9d7ca82..0000000
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
-inherit bash-completion-r1 distutils-r1 eutils
-
-DESCRIPTION="Download videos from YouTube.com (and more sites...)"
-HOMEPAGE="https://rg3.github.com/youtube-dl/"
-SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE="offensive test"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/nose[coverage(+)] )
-"
-
-S="${WORKDIR}/${PN}"
-
-python_prepare_all() {
-       if ! use offensive; then
-               sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
-                       youtube_dl/version.py || die
-               # these have single line import statements
-               local xxx=(
-                       alphaporno anysex behindkink camwithher chaturbate drtuber eporner
-                       eroprofile extremetube fourtube foxgay goshgay hellporno
-                       hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
-                       myvidster porn91 pornhd pornotube pornovoisines pornoxo redtube
-                       ruleporn sexu slutload spankbang spankwire sunporno thisav trutube
-                       tube8 vporn watchindianporn xbef xnxx xtube xvideos xxxymovies
-                       youjizz youporn
-               )
-               # these have multi-line import statements
-               local mxxx=(
-                       pornhub xhamster tnaflix
-               )
-               # do single line imports
-               sed -i \
-                       -e $( printf '/%s/d;' ${xxx[@]} ) \
-                       youtube_dl/extractor/extractors.py \
-                       || die
-
-               # do multiple line imports
-               sed -i \
-                       -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
-                       youtube_dl/extractor/extractors.py \
-                       || die
-
-               sed -i \
-                       -e $( printf '/%s/d;' ${mxxx[@]} ) \
-                       youtube_dl/extractor/generic.py \
-                       || die
-
-               rm \
-                       $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
-                       $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
-                       test/test_age_restriction.py \
-                       || die
-       fi
-
-       epatch_user
-
-       distutils-r1_python_prepare_all
-}
-
-src_compile() {
-       distutils-r1_src_compile
-}
-
-python_test() {
-       emake test
-}
-
-python_install_all() {
-       dodoc README.txt
-       doman ${PN}.1
-
-       newbashcomp ${PN}.bash-completion ${PN}
-
-       insinto /usr/share/zsh/site-functions
-       newins youtube-dl.zsh _youtube-dl
-
-       insinto /usr/share/fish/completions
-       doins youtube-dl.fish
-
-       distutils-r1_python_install_all
-}