sci-physics/root: add USE=mpi support
authorGuilherme Amadio <amadio@gentoo.org>
Wed, 11 Mar 2020 16:37:31 +0000 (17:37 +0100)
committerGuilherme Amadio <amadio@gentoo.org>
Thu, 12 Mar 2020 07:21:39 +0000 (08:21 +0100)
This is a new feature from ROOT 6.20.00 and later.

Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
sci-physics/root/root-6.20.00-r1.ebuild
sci-physics/root/root-9999.ebuild

index d2fe9958e65c065eec634d84d61a1e6416e9cd68..9bb1b81ae15d7984f29e6d621a76c7b353e1ce45 100644 (file)
@@ -17,7 +17,7 @@ SRC_URI="https://root.cern/download/${PN}_v${PV}.source.tar.gz"
 
 IUSE="+X aqua +asimage +c++11 c++14 c++17 cuda +davix debug emacs
        +examples fits fftw fortran +gdml graphviz +gsl http libcxx +minuit
-       mysql odbc +opengl oracle postgres prefix pythia6 pythia8 +python
+       mpi mysql odbc +opengl oracle postgres prefix pythia6 pythia8 +python
        qt5 R +roofit root7 shadow sqlite +ssl +tbb test +tmva +unuran vc
        vmc +xml xrootd"
 RESTRICT="!test? ( test )"
@@ -79,6 +79,7 @@ CDEPEND="
        libcxx? ( sys-libs/libcxx )
        unuran? ( sci-mathematics/unuran:0= )
        minuit? ( !sci-libs/minuit )
+       mpi? ( virtual/mpi )
        mysql? ( dev-db/mysql-connector-c )
        odbc? ( || ( dev-db/libiodbc dev-db/unixODBC ) )
        oracle? ( dev-db/oracle-instantclient-basic )
@@ -210,6 +211,7 @@ src_configure() {
                -Dminuit=$(usex minuit)
                -Dmlp=$(usex tmva)
                -Dmonalisa=OFF
+               -Dmpi=$(usex mpi)
                -Dmysql=$(usex mysql)
                -Dodbc=$(usex odbc)
                -Dopengl=$(usex opengl)
index bc4a2339916b57841dc1589bca80121a90b9cc5a..172980d28a2866a8db1bd67c1092b1f28ff504de 100644 (file)
@@ -16,7 +16,7 @@ HOMEPAGE="https://root.cern"
 
 IUSE="+X aqua +asimage +c++11 c++14 c++17 cuda cudnn +davix debug emacs
        +examples fits fftw fortran +gdml graphviz +gsl http libcxx +minuit
-       mysql odbc +opengl oracle postgres prefix pythia6 pythia8 +python
+       mpi mysql odbc +opengl oracle postgres prefix pythia6 pythia8 +python
        qt5 R +roofit root7 shadow sqlite +ssl +tbb test +tmva +unuran vc
        vmc +xml xrootd"
 RESTRICT="!test? ( test )"
@@ -93,6 +93,7 @@ CDEPEND="
        libcxx? ( sys-libs/libcxx )
        unuran? ( sci-mathematics/unuran:0= )
        minuit? ( !sci-libs/minuit )
+       mpi? ( virtual/mpi )
        mysql? ( dev-db/mysql-connector-c )
        odbc? ( || ( dev-db/libiodbc dev-db/unixODBC ) )
        oracle? ( dev-db/oracle-instantclient-basic )
@@ -225,6 +226,7 @@ src_configure() {
                -Dminuit=$(usex minuit)
                -Dmlp=$(usex tmva)
                -Dmonalisa=OFF
+               -Dmpi=$(usex mpi)
                -Dmysql=$(usex mysql)
                -Dodbc=$(usex odbc)
                -Dopengl=$(usex opengl)