dev-python/zope-event: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sun, 29 Mar 2020 12:15:16 +0000 (14:15 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 29 Mar 2020 12:20:08 +0000 (14:20 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/zope-event/Manifest
dev-python/zope-event/zope-event-4.2.0.ebuild [deleted file]
dev-python/zope-event/zope-event-4.3.0.ebuild [deleted file]

index 4dbba96e9ace6f70d5802e2fbd19b34d9c078ef4..17b6b06976910d606720438efb0e114b9a1a725a 100644 (file)
@@ -1,3 +1 @@
-DIST zope.event-4.2.0.tar.gz 488532 BLAKE2B 89c2c2e9e75a57afd43f7ee984cbe8f7add3cb4eaf1271695b2a5c31e77e5fccb0c884d3f8c44c54fbd06be209e4556bc2438cda9bc987124d46e795822bd841 SHA512 e39cbbccf679328db190f0641e3cb0d267fc606afc9cdbd4fb4100bde482f12f594319d885db101dfd98741225604bb49ef77094011bbe7edaa16877038f9989
-DIST zope.event-4.3.0.tar.gz 17829 BLAKE2B 5d508c834321c70399eb9888bc2b000f5b18de625c68dc089f3ab8571a7948c1e43e76c62811c955777fc2caa65585347c124e24f2afc46b23e9d30b6c4a4599 SHA512 dad303d1b76c75dcc98f1164c6dec8f8458f1adc4109146942cf9ff40ed3f92579b2da742b10798bc720ab17cbdebc86e54008cfa5155616e2ac68b332e62571
 DIST zope.event-4.4.tar.gz 18818 BLAKE2B 628625280c1e3f06f2c2e6e9aa88d3e34958718ea4624d54a5b915f8a570e38d4893adc0a0c688a7f09d3c81ffd67fbb69a3bc89ad58d95be498c2de48fff697 SHA512 34dac7ce2e8faf464bdb3861217beb1dd0976b1cc047d45a79f1640dd256bf33162da6e105c00135217fcdb888fc3ac7a4b0b4b047f64ce310c4d11cff71a985
diff --git a/dev-python/zope-event/zope-event-4.2.0.ebuild b/dev-python/zope-event/zope-event-4.2.0.ebuild
deleted file mode 100644 (file)
index 3d1b742..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
-
-inherit distutils-r1
-MY_PN=zope.event
-
-MY_P=${MY_PN}-${PV}
-DESCRIPTION="Event publishing / dispatch, used by Zope Component Architecture"
-HOMEPAGE="https://github.com/zopefoundation/zope.event http://docs.zope.org/zope.event/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )
-       dev-python/setuptools[${PYTHON_USEDEP}]"
-
-S=${WORKDIR}/${MY_P}
-
-python_test() {
-       nosetests || die
-}
diff --git a/dev-python/zope-event/zope-event-4.3.0.ebuild b/dev-python/zope-event/zope-event-4.3.0.ebuild
deleted file mode 100644 (file)
index 28da396..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
-
-inherit distutils-r1
-
-MY_PN=zope.event
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Event publishing / dispatch, used by Zope Component Architecture"
-HOMEPAGE="https://github.com/zopefoundation/zope.event http://docs.zope.org/zope.event/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-RDEPEND="dev-python/namespace-zope[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-distutils_enable_tests nose
-
-python_install_all() {
-       distutils-r1_python_install_all
-
-       # remove .pth files since dev-python/namespace-zope handles the ns
-       find "${D}" -name '*.pth' -delete || die
-}