net-libs/libnet: Version 1.2_rc4
authorJeroen Roovers <jer@gentoo.org>
Wed, 9 Oct 2019 06:33:25 +0000 (08:33 +0200)
committerJeroen Roovers <jer@gentoo.org>
Wed, 9 Oct 2019 06:39:15 +0000 (08:39 +0200)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-libs/libnet/Manifest
net-libs/libnet/libnet-1.2.9999.ebuild
net-libs/libnet/libnet-1.2_rc4.ebuild [new file with mode: 0644]

index fba13d83980f09b75c13e47192bb8772d1bac1b8..6cac2ef87a76225ab0632c793e32f86a71e5960f 100644 (file)
@@ -1,2 +1,3 @@
 DIST libnet-1.0.2a.tar.gz 140191 BLAKE2B 4107cb714b7be901250759ce5288a86922bd7cc20081a9d2c93758150d74c55844db98c43874befdfb593ec25e128d6ae2389eff7c46da79dcbb9681f649e059 SHA512 2e9a73bd767e1f46eea92e18ddd83cc3179144c8cc5b1a22b4dba50fee16173c951be4dd647a247bd7067c33b9e33489a6efb313ce1ea0c61c4a06009c3c4d95
 DIST libnet-1.2-rc3.tar.gz 676205 BLAKE2B f1aa199489e9aacc6b2bf567f5885e3b54b1044fb292693581c8fbc8fb99c565e0a9436b35914bdbda65798b00527049f279da3b3b6048e32f575f51b92c3309 SHA512 4f1c5c1a72e2c35ca3add772cb1af63e8245bb5c127e4a74fb9f619f987a4ea047bf17caaa292e9b7fa7642635773b90975d013644be0383dca93d688ca8430d
+DIST libnet-1.2-rc4.tar.gz 615726 BLAKE2B 90d2a98dc52c32ff7d97edd4f85c04e56ba5c9300b39fff560f39078dbfd451474118168c291db1fa13fb0d6af123c23a604e03d0f88609a0c131c694cffd755 SHA512 01c815c9e544f00a2b35372466ff8b372b132e3d4ee7b99557f799e0b4380777bebde2ce9bdd804314dffe88ce953f332923d9fa2bf3c186ea19e045b94edbcd
index 1059f3a86ceae3a3135e69a594199b6c9483bcb5..107f73751b55d92d4f1679752df362d234370205 100644 (file)
@@ -5,8 +5,8 @@ EAPI=7
 inherit autotools git-r3
 
 DESCRIPTION="library providing an API for commonly used low-level network functions"
-HOMEPAGE="http://libnet-dev.sourceforge.net/ https://github.com/sam-github/libnet"
-EGIT_REPO_URI="https://github.com/sam-github/libnet"
+HOMEPAGE="http://libnet-dev.sourceforge.net/ https://github.com/libnet/libnet"
+EGIT_REPO_URI="https://github.com/libnet/libnet"
 
 LICENSE="BSD BSD-2 HPND"
 SLOT="1.1"
diff --git a/net-libs/libnet/libnet-1.2_rc4.ebuild b/net-libs/libnet/libnet-1.2_rc4.ebuild
new file mode 100644 (file)
index 0000000..e4c9ab4
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="library providing an API for commonly used low-level network functions"
+HOMEPAGE="http://libnet-dev.sourceforge.net/ https://github.com/libnet/libnet"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV/_/-}/${P/_/-}.tar.gz"
+
+LICENSE="BSD BSD-2 HPND"
+SLOT="1.1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="static-libs"
+
+DOCS=(
+       ChangeLog.md README.md doc/{MIGRATION,RAWSOCKET_NON_SEQUITUR,TODO}
+)
+S=${WORKDIR}/${P/_/-}
+
+src_configure() {
+       econf $(use_enable static-libs static)
+}
+
+src_install() {
+       default
+
+       find "${D}" -name '*.la' -delete || die
+}