Make installation of static libraries optional, reported by ago
authorNirbheek Chauhan <nirbheek@gentoo.org>
Wed, 4 Jan 2012 20:07:00 +0000 (20:07 +0000)
committerNirbheek Chauhan <nirbheek@gentoo.org>
Wed, 4 Jan 2012 20:07:00 +0000 (20:07 +0000)
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64

net-libs/ptlib/ChangeLog
net-libs/ptlib/ptlib-2.6.7-r1.ebuild

index 7adef4f295658ecaab34f03fd2eea01a947af539..365b611eb1a1b09fa7d5980c6277ddf0fe5340ee 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for net-libs/ptlib
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ChangeLog,v 1.27 2011/10/30 15:50:27 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ChangeLog,v 1.28 2012/01/04 20:07:00 nirbheek Exp $
+
+  04 Jan 2012; Nirbheek Chauhan <nirbheek@gentoo.org> ptlib-2.6.7-r1.ebuild:
+  Make installation of static libraries optional, reported by ago
 
   30 Oct 2011; Samuli Suominen <ssuominen@gentoo.org> ptlib-2.6.7-r1.ebuild:
   Rename obsolete USE="v4l2" to USE="v4l" wrt #385241
index 5dcfa5524929b8cab42128e6dc20f8e7de53daf7..978925dab719695db710ce2efe0586ef8dbbf168 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ptlib-2.6.7-r1.ebuild,v 1.7 2011/10/30 15:50:27 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ptlib-2.6.7-r1.ebuild,v 1.8 2012/01/04 20:07:00 nirbheek Exp $
 
 EAPI="2"
 
@@ -18,7 +18,7 @@ KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc x86"
 # default enabled are features from 'minsize', the most used according to ptlib
 IUSE="alsa +asn +audio debug doc dtmf esd examples ffmpeg ftp http ipv6
 jabber ldap mail odbc oss pch qos remote sasl sdl serial shmvideo snmp soap
-socks ssl +stun telnet tts v4l +video vxml wav xml xmlrpc"
+socks ssl static-libs +stun telnet tts v4l +video vxml wav xml xmlrpc"
 
 CDEPEND="
        audio? ( alsa? ( media-libs/alsa-lib )
@@ -220,6 +220,12 @@ src_install() {
 
        emake DESTDIR="${D}" ${makeopts} install || die "emake install failed"
 
+       # Get rid of static libraries if not requested
+       # There seems to be no easy way to disable this in the build system
+       if ! use static-libs; then
+               rm -v "${D}"/usr/lib*/*.a || die
+       fi
+
        if use doc; then
                dohtml -r "${WORKDIR}"/html/* || die "dohtml failed"
        fi