Version bump.
authorChristian Zoffoli <xmerlin@gentoo.org>
Tue, 19 Dec 2006 21:19:14 +0000 (21:19 +0000)
committerChristian Zoffoli <xmerlin@gentoo.org>
Tue, 19 Dec 2006 21:19:14 +0000 (21:19 +0000)
Package-Manager: portage-2.1-r1

sys-cluster/drbd/ChangeLog
sys-cluster/drbd/drbd-0.7.22.ebuild [new file with mode: 0644]
sys-cluster/drbd/drbd-8.0_pre6.ebuild [new file with mode: 0644]
sys-cluster/drbd/files/digest-drbd-0.7.22 [new file with mode: 0644]
sys-cluster/drbd/files/digest-drbd-8.0_pre6 [new file with mode: 0644]

index da0bb6ba1713d0173f016055ab3be62f32ff733c..aec52e28347d705afeaf56b76c58f2d5a84f8fde 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for sys-cluster/drbd
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/drbd/ChangeLog,v 1.56 2006/12/19 21:15:56 xmerlin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/drbd/ChangeLog,v 1.57 2006/12/19 21:19:14 xmerlin Exp $
+
+*drbd-8.0_pre6 (19 Dec 2006)
+
+  19 Dec 2006; Christian Zoffoli <xmerlin@gentoo.org> +drbd-8.0_pre6.ebuild:
+  Version bump.
 
 *drbd-0.7.22 (19 Dec 2006)
 
diff --git a/sys-cluster/drbd/drbd-0.7.22.ebuild b/sys-cluster/drbd/drbd-0.7.22.ebuild
new file mode 100644 (file)
index 0000000..ff53cb5
--- /dev/null
@@ -0,0 +1,76 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/drbd/drbd-0.7.22.ebuild,v 1.1 2006/12/19 21:15:56 xmerlin Exp $
+
+inherit eutils versionator linux-mod linux-info
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+MY_MAJ_PV="$(get_version_component_range 1-2 ${PV})"
+DESCRIPTION="mirror/replicate block-devices across a network-connection"
+SRC_URI="http://oss.linbit.com/drbd/${MY_MAJ_PV}/${P}.tar.gz"
+HOMEPAGE="http://www.drbd.org"
+
+IUSE=""
+
+DEPEND="virtual/linux-sources"
+RDEPEND=""
+SLOT="0"
+
+pkg_setup() {
+       linux-mod_pkg_setup
+}
+
+src_compile() {
+       set_arch_to_kernel
+
+       einfo ""
+       einfo "Your kernel-sources in /usr/src/linux-${KV} must be properly configured"
+       #einfo "and match the currently running kernel version ${KV}"
+       einfo "If otherwise -> build will fail."
+       einfo ""
+
+       if kernel_is 2 6; then
+               emake KDIR=${KERNEL_DIR} || die "compile problem"
+       else
+               cp -R /usr/src/linux-${KV} ${WORKDIR}
+               emake KDIR=/${WORKDIR}/linux-${KV} || die "compile problem"
+       fi
+}
+
+src_install() {
+       emake PREFIX=${D} install || die "install problem"
+
+       # gentoo-ish init-script
+       newinitd ${FILESDIR}/${PN}-0.7.rc ${PN} || die
+
+       # needed by drbd startup script
+       #keepdir /var/lib/drbd
+
+       # docs
+       dodoc README ChangeLog COPYING
+       dodoc documentation/NFS-Server-README.txt
+
+       # we put drbd.conf into docs
+       # it doesnt make sense to install a default conf in /etc
+       # put it to the docs
+       rm -f ${D}/etc/drbd.conf
+       dodoc scripts/drbd.conf || die
+       dodoc upgrade_0.6.x_to_0.7.0.txt upgrade_0.7.0_to_0.7.1.txt || die
+}
+
+pkg_postinst() {
+       linux-mod_pkg_postinst
+
+       einfo ""
+       einfo "Please remember to re-emerge drbd when you upgrade your kernel!"
+       einfo ""
+       einfo "Please copy and gunzip the configuration file"
+       einfo "from /usr/share/doc/${PF}/drbd.conf.gz to /etc"
+       einfo "and edit it to your needs. Helpful commands:"
+       einfo "man 5 drbd.conf"
+       einfo "man 8 drbdsetup"
+       einfo "man 8 drbdadm"
+       einfo ""
+}
diff --git a/sys-cluster/drbd/drbd-8.0_pre6.ebuild b/sys-cluster/drbd/drbd-8.0_pre6.ebuild
new file mode 100644 (file)
index 0000000..474a148
--- /dev/null
@@ -0,0 +1,80 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/drbd/drbd-8.0_pre6.ebuild,v 1.1 2006/12/19 21:19:14 xmerlin Exp $
+
+inherit eutils versionator linux-mod linux-info
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+MY_PV="${PV/_/}"
+MY_MAJ_PV="$(get_version_component_range 1-2 ${PV})"
+DESCRIPTION="mirror/replicate block-devices across a network-connection"
+SRC_URI="http://oss.linbit.com/drbd/${MY_MAJ_PV}/${PN}-${MY_PV}.tar.gz"
+HOMEPAGE="http://www.drbd.org"
+
+IUSE=""
+
+DEPEND="virtual/linux-sources"
+RDEPEND=""
+SLOT="0"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+pkg_setup() {
+       linux-mod_pkg_setup
+}
+
+src_compile() {
+       set_arch_to_kernel
+
+       einfo ""
+       einfo "Your kernel-sources in /usr/src/linux-${KV} must be properly configured"
+       einfo "If otherwise -> build will fail."
+       einfo ""
+
+       if kernel_is 2 6; then
+               emake KDIR=${KERNEL_DIR} || die "compile problem"
+       else
+               cp -R /usr/src/linux-${KV} ${WORKDIR}
+               emake KDIR=/${WORKDIR}/linux-${KV} || die "compile problem"
+       fi
+}
+
+src_install() {
+       emake PREFIX=${D} install || die "install problem"
+
+       # gentoo-ish init-script
+       newinitd ${FILESDIR}/${PN}-0.7.rc ${PN} || die
+
+       # needed by drbd startup script
+       #keepdir /var/lib/drbd
+
+       # docs
+       dodoc README ChangeLog COPYING ROADMAP INSTALL
+       #dodoc documentation/NFS-Server-README.txt
+
+       # we put drbd.conf into docs
+       # it doesnt make sense to install a default conf in /etc
+       # put it to the docs
+       rm -f ${D}/etc/drbd.conf
+       dodoc scripts/drbd.conf || die
+       #dodoc upgrade*.txt || die
+}
+
+pkg_postinst() {
+       linux-mod_pkg_postinst
+
+       einfo ""
+       einfo "Please remember to re-emerge drbd when you upgrade your kernel!"
+       einfo ""
+       einfo "Please copy and gunzip the configuration file"
+       einfo "from /usr/share/doc/${PF}/drbd.conf.gz to /etc"
+       einfo "and edit it to your needs. Helpful commands:"
+       einfo "man 5 drbd.conf"
+       einfo "man 8 drbdsetup"
+       einfo "man 8 drbdadm"
+       einfo "man 8 drbddisk"
+       einfo "man 8 drbdmeta"
+       einfo ""
+}
diff --git a/sys-cluster/drbd/files/digest-drbd-0.7.22 b/sys-cluster/drbd/files/digest-drbd-0.7.22
new file mode 100644 (file)
index 0000000..ce9279e
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 589626e0c62d314d3bbe78275b9e7d2d drbd-0.7.22.tar.gz 296960
+RMD160 d187a23197b52cdced97cf24bda252c8da4f752f drbd-0.7.22.tar.gz 296960
+SHA256 1c29e22250e4aa874ac146edae6c6c4254cc96d508fc0f38b3a3ec885a05f2c8 drbd-0.7.22.tar.gz 296960
diff --git a/sys-cluster/drbd/files/digest-drbd-8.0_pre6 b/sys-cluster/drbd/files/digest-drbd-8.0_pre6
new file mode 100644 (file)
index 0000000..4d1c0af
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 17967d6bcf27c56aea3fc9b7481c0851 drbd-8.0pre6.tar.gz 460800
+RMD160 1aaf06cf95d2ca76ac228a5c9d9e96365f935c0c drbd-8.0pre6.tar.gz 460800
+SHA256 2323d8e9d99f9d7ab630c8b3cc358768404b2a7bf77d036ab1073c8478b047d9 drbd-8.0pre6.tar.gz 460800