Do the sanity check for bug #198398 as early as possible.
authorZac Medico <zmedico@gentoo.org>
Thu, 13 Dec 2007 05:37:52 +0000 (05:37 -0000)
committerZac Medico <zmedico@gentoo.org>
Thu, 13 Dec 2007 05:37:52 +0000 (05:37 -0000)
svn path=/main/trunk/; revision=8897

bin/repoman

index c921234fddac7af1c06b798e86783169e1d61344..96937a0734b50e77dde41875c826ceb36fa305c9 100755 (executable)
@@ -418,6 +418,24 @@ myreporoot=None
 if os.path.isdir("CVS"):
        isCvs = True
 
+if isCvs and \
+       "commit" == options.mode and \
+       "RMD160" not in portage.checksum.hashorigin_map:
+       from portage.util import grablines
+       repo_lines = grablines("./CVS/Repository")
+       if repo_lines and \
+               "gentoo-x86" == repo_lines[0].strip().split(os.path.sep)[0]:
+               msg = "Please install " \
+               "pycrypto or enable python's ssl USE flag in order " \
+               "to enable RMD160 hash support. See bug #198398 for " \
+               "more information."
+               prefix = red(" * ")
+               from textwrap import wrap
+               for line in wrap(msg, 70):
+                       print prefix + line
+               sys.exit(1)
+       del repo_lines
+
 if options.mode == 'commit' and not options.pretend and not isCvs:
        logging.info("Not in a CVS repository; enabling pretend mode.")
        options.pretend = True
@@ -809,21 +827,6 @@ if isCvs:
        mynew = cvstree.findnew(mycvstree, recursive=1, basedir="./")
        new_ebuilds.update(x for x in mynew if x.endswith(".ebuild"))
        del mycvstree, mynew
-       if "commit" == options.mode and \
-               "RMD160" not in portage.checksum.hashorigin_map:
-               from portage.util import grablines
-               repo_lines = grablines("./CVS/Repository")
-               if repo_lines and \
-                       "gentoo-x86" == repo_lines[0].strip().split(os.path.sep)[0]:
-                       msg = "Please install " \
-                       "pycrypto or enable python's ssl USE flag in order " \
-                       "to enable RMD160 hash support. See bug #198398 for " \
-                       "more information."
-                       prefix = red(" * ")
-                       from textwrap import wrap
-                       for line in wrap(msg, 70):
-                               print prefix + line
-                       sys.exit(1)
 
 dofail = 0
 arch_caches={}