dev-php/PEAR-Var_Dump: Revision bump for new eclass
authorBrian Evans <grknight@gentoo.org>
Fri, 3 Mar 2017 19:15:13 +0000 (14:15 -0500)
committerBrian Evans <grknight@gentoo.org>
Fri, 3 Mar 2017 19:29:20 +0000 (14:29 -0500)
Package-Manager: Portage-2.3.4, Repoman-2.3.2

dev-php/PEAR-Var_Dump/PEAR-Var_Dump-1.0.4-r3.ebuild [new file with mode: 0644]

diff --git a/dev-php/PEAR-Var_Dump/PEAR-Var_Dump-1.0.4-r3.ebuild b/dev-php/PEAR-Var_Dump/PEAR-Var_Dump-1.0.4-r3.ebuild
new file mode 100644 (file)
index 0000000..707cff1
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+DESCRIPTION="Dump structured information about a variable"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples test"
+
+DEPEND="test? ( dev-php/PEAR-PEAR )"
+
+# The test suite fails due to some deprecation warnings that are output.
+# The test cases themselves set error_reporting(E_ALL), so there's no
+# easy way to override it.
+RESTRICT=test
+
+src_install() {
+       use examples && dodoc -r docs/example*.php
+       php-pear-r2_src_install
+}
+
+src_test() {
+       # Requires the "pear" executable from dev-php/PEAR-PEAR.
+       pear run-tests tests || die
+
+       # The command succeeds regardless of whether or not the test suite
+       # passed, but this file is only written when there was a failure.
+       [[ -f run-tests.log ]] && die "test suite failed"
+}