x11-wm/stumpwm: Reset XDG environment.
authorChema Alonso Josa <nimiux@gentoo.org>
Sun, 22 Jan 2017 16:20:33 +0000 (17:20 +0100)
committerChema Alonso Josa <nimiux@gentoo.org>
Sun, 22 Jan 2017 16:20:59 +0000 (17:20 +0100)
Fixes bug #606484

Package-Manager: portage-2.3.0

x11-wm/stumpwm/stumpwm-1.0.0.ebuild

index 58bfb84dabcedf10af38f2c949d925a62dede975..b3c7548eee00f7b2c40b41dad40551377c6142ea 100644 (file)
@@ -4,7 +4,7 @@
 
 EAPI=6
 
-inherit common-lisp-3 eutils elisp-common autotools
+inherit common-lisp-3 eutils elisp-common autotools xdg-utils
 
 DESCRIPTION="Stumpwm is a Window Manager written entirely in Common Lisp."
 HOMEPAGE="https://stumpwm.github.io/"
@@ -73,6 +73,7 @@ src_prepare() {
 src_configure() {
        local moduleconfig
 
+       xdg_environment_reset
        use contrib && moduleconfig="--with-module-dir=${CONTRIBDIR}/contrib"
        econf --with-lisp=$(get_lisp sbcl clisp ecl) "${moduleconfig}"
 }