app-text/poppler: Drop 0.79.0-r1
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 28 Dec 2019 16:00:47 +0000 (17:00 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 28 Dec 2019 16:09:53 +0000 (17:09 +0100)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
app-text/poppler/Manifest
app-text/poppler/files/poppler-0.78.0-respect-cflags.patch [deleted file]
app-text/poppler/poppler-0.79.0-r1.ebuild [deleted file]

index 13e1660146711645b7772edf7771785ccccf3945..45d4ec9453b886580f9f78e42a51ccf5a77e97e4 100644 (file)
@@ -1,3 +1,2 @@
-DIST poppler-0.79.0.tar.xz 1544140 BLAKE2B b5ecf204c5246f640d9f5ca5ffce9648a1a2c957efdb1e31ace9c1ccdff1be85337b67f7c4019b52eefce17e6f5869aa1911a60e54e421b80ddd3b6eec97a0ec SHA512 f0024fb86887e147ec1cbe9481498d348076dbd6b960716da65defab3365c67ab39626f946758dddbe438634a7116773d8ded8684b65e18abbfc299f56563ec9
 DIST poppler-0.82.0.tar.xz 1553336 BLAKE2B a83d476ce1174cb7789f857a52a8a9ed29dfe8863d082ef662508ad9957667349aa62b038fa1a52e9e7ae3ddf4701eb5fbd58545b041b6aebd69cb8b91376d8d SHA512 1631be30e398dd18a4e8c2cc893cf0d9469a98d93f02f2ffe3bc14857518b76674a10cafe89ee92b9886c3c6b03d50e214a6838c102f673a62789c9832cfa4a2
 DIST poppler-0.83.0.tar.xz 1555456 BLAKE2B 4ab24a85e879d0ddbf24cf7bab5b1da7c15fc026e88b4076dc2b8cd34d69a5bcc0113df20fabda6915afea880480613ba34be6e23b5b0d79a3c6197c92af7853 SHA512 bfde1e3cc4d9c626949aab770d84fccbe47bdde2331d3b9f5b98c24319eb573a5db62acbfa5a524b21ed0f195f8b163fee64677c2bd616d31d0bb219d1e66713
diff --git a/app-text/poppler/files/poppler-0.78.0-respect-cflags.patch b/app-text/poppler/files/poppler-0.78.0-respect-cflags.patch
deleted file mode 100644 (file)
index 137af0d..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
---- poppler-0.78.0/cmake/modules/PopplerMacros.cmake
-+++ poppler-0.78.0/cmake/modules/PopplerMacros.cmake
-@@ -145,28 +145,6 @@
-   endif(GCC_HAS_AS_NEEDED)
- endif (CMAKE_COMPILER_IS_GNUCXX)
--if ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
--# set the default compile warnings
--  set(_warn "-Wall -Wextra -Wpedantic")
--  set(_warn "${_warn} -Wno-unused-parameter")
--  set(_warn "${_warn} -Wcast-align")
--  set(_warn "${_warn} -Wformat-security")
--  set(_warn "${_warn} -Wframe-larger-than=65536")
--  set(_warn "${_warn} -Wmissing-format-attribute")
--  set(_warn "${_warn} -Wnon-virtual-dtor")
--  set(_warn "${_warn} -Woverloaded-virtual")
--  set(_warn "${_warn} -Wmissing-declarations")
--  set(_warn "${_warn} -Wundef")
--  set(_warn "${_warn} -Wzero-as-null-pointer-constant")
--  set(_warn "${_warn} -Wshadow")
--
--  # set extra warnings
--  set(_warnx "${_warnx} -Wconversion")
--
--  set(DEFAULT_COMPILE_WARNINGS "${_warn}")
--  set(DEFAULT_COMPILE_WARNINGS_EXTRA "${_warn} ${_warnx}")
--endif()
--
- if(CMAKE_C_COMPILER MATCHES "icc")
-   set(_save_cxxflags "${CMAKE_CXX_FLAGS}")
-   set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "-O2 -g ${_save_cxxflags}")
diff --git a/app-text/poppler/poppler-0.79.0-r1.ebuild b/app-text/poppler/poppler-0.79.0-r1.ebuild
deleted file mode 100644 (file)
index 7043b93..0000000
+++ /dev/null
@@ -1,127 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake-utils flag-o-matic toolchain-funcs xdg-utils
-
-if [[ ${PV} == *9999* ]] ; then
-       inherit git-r3
-       EGIT_REPO_URI="https://anongit.freedesktop.org/git/poppler/poppler.git"
-       SLOT="0/9999"
-else
-       SRC_URI="https://poppler.freedesktop.org/${P}.tar.xz"
-       KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-       SLOT="0/89"   # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
-fi
-
-DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
-HOMEPAGE="https://poppler.freedesktop.org/"
-
-LICENSE="GPL-2"
-IUSE="cairo cjk curl cxx debug doc +introspection +jpeg +jpeg2k +lcms nss png qt5 tiff +utils"
-
-# No test data provided
-RESTRICT="test"
-
-BDEPEND="
-       dev-util/glib-utils
-       virtual/pkgconfig
-"
-DEPEND="
-       media-libs/fontconfig
-       media-libs/freetype
-       sys-libs/zlib
-       cairo? (
-               dev-libs/glib:2
-               x11-libs/cairo
-               introspection? ( dev-libs/gobject-introspection:= )
-       )
-       curl? ( net-misc/curl )
-       jpeg? ( virtual/jpeg:0 )
-       jpeg2k? ( >=media-libs/openjpeg-2.3.0-r1:2= )
-       lcms? ( media-libs/lcms:2 )
-       nss? ( >=dev-libs/nss-3.19:0 )
-       png? ( media-libs/libpng:0= )
-       qt5? (
-               dev-qt/qtcore:5
-               dev-qt/qtgui:5
-               dev-qt/qtxml:5
-       )
-       tiff? ( media-libs/tiff:0 )
-"
-RDEPEND="${DEPEND}
-       cjk? ( app-text/poppler-data )
-"
-
-DOCS=( AUTHORS NEWS README.md README-XPDF )
-
-PATCHES=(
-       "${FILESDIR}/${PN}-0.60.1-qt5-dependencies.patch"
-       "${FILESDIR}/${PN}-0.28.1-fix-multilib-configuration.patch"
-       "${FILESDIR}/${PN}-0.78.0-respect-cflags.patch"
-       "${FILESDIR}/${PN}-0.61.0-respect-cflags.patch"
-       "${FILESDIR}/${PN}-0.57.0-disable-internal-jpx.patch"
-)
-
-src_prepare() {
-       cmake-utils_src_prepare
-
-       # Clang doesn't grok this flag, the configure nicely tests that, but
-       # cmake just uses it, so remove it if we use clang
-       if [[ ${CC} == clang ]] ; then
-               sed -e 's/-fno-check-new//' -i cmake/modules/PopplerMacros.cmake || die
-       fi
-
-       if ! grep -Fq 'cmake_policy(SET CMP0002 OLD)' CMakeLists.txt ; then
-               sed -e '/^cmake_minimum_required/acmake_policy(SET CMP0002 OLD)' \
-                       -i CMakeLists.txt || die
-       else
-               einfo "policy(SET CMP0002 OLD) - workaround can be removed"
-       fi
-
-       # we need to up the C++ version, bug #622526, #643278
-       append-cxxflags -std=c++11
-}
-
-src_configure() {
-       xdg_environment_reset
-       local mycmakeargs=(
-               -DBUILD_GTK_TESTS=OFF
-               -DBUILD_QT5_TESTS=OFF
-               -DBUILD_CPP_TESTS=OFF
-               -DENABLE_SPLASH=ON
-               -DENABLE_ZLIB=ON
-               -DENABLE_ZLIB_UNCOMPRESS=OFF
-               -DENABLE_UNSTABLE_API_ABI_HEADERS=ON
-               -DSPLASH_CMYK=OFF
-               -DUSE_FIXEDPOINT=OFF
-               -DUSE_FLOAT=OFF
-               -DWITH_Cairo=$(usex cairo)
-               -DENABLE_LIBCURL=$(usex curl)
-               -DENABLE_CPP=$(usex cxx)
-               -DWITH_JPEG=$(usex jpeg)
-               -DENABLE_DCTDECODER=$(usex jpeg libjpeg none)
-               -DENABLE_LIBOPENJPEG=$(usex jpeg2k openjpeg2 none)
-               -DENABLE_CMS=$(usex lcms lcms2 none)
-               -DWITH_NSS3=$(usex nss)
-               -DWITH_PNG=$(usex png)
-               $(cmake-utils_use_find_package qt5 Qt5Core)
-               -DWITH_TIFF=$(usex tiff)
-               -DENABLE_UTILS=$(usex utils)
-       )
-       use cairo && mycmakeargs+=( -DWITH_GObjectIntrospection=$(usex introspection) )
-
-       cmake-utils_src_configure
-}
-
-src_install() {
-       cmake-utils_src_install
-
-       # live version doesn't provide html documentation
-       if use cairo && use doc && [[ ${PV} != *9999* ]]; then
-               # For now install gtk-doc there
-               insinto /usr/share/gtk-doc/html/poppler
-               doins -r "${S}"/glib/reference/html/*
-       fi
-}