dev-python/imapclient: Clean old up
authorMichał Górny <mgorny@gentoo.org>
Thu, 4 Jan 2018 20:37:49 +0000 (21:37 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 4 Jan 2018 21:50:30 +0000 (22:50 +0100)
dev-python/imapclient/Manifest
dev-python/imapclient/imapclient-0.12.ebuild [deleted file]

index d34758a74b3e752a84787069f5663c3bed6a248b..38d18b9e8f3b9d4925f234cf9317f5c02f90cd90 100644 (file)
@@ -1,2 +1 @@
-DIST IMAPClient-0.12.tar.gz 100698 BLAKE2B d5a9ce4285d468ac827c4f33b140317cbff45e28b503e601e2755463957d3eca0144e54f6f59b9564bd1d530d77f791714bd4a72fc44da7e4aace34970bac5a0 SHA512 bd7d3e3911ff5ef1cc4a66f20e261955851562e76228f941d35f16a4680678be6a3741d520cc3133925a2dba9e8b6b5b988d7a740ff8abb63c14db1cf962acda
 DIST IMAPClient-0.13.tar.gz 102427 BLAKE2B f087b6e89c45810f359bed889345e6748ebf9ae90f6e3c4e013097a4e57d3f5ab0ec21906cfdccc03a344d92ccc442d58e38e687cd0761d86956047e89fedb03 SHA512 daebaf7f4180b6c9c6f4a486b313abfdd06f3ed8ece18a19bf46a50e56c2094e85de8a8e4efb8850566378eba016c10816611d03852caf637ee1d43f3c8a418f
diff --git a/dev-python/imapclient/imapclient-0.12.ebuild b/dev-python/imapclient/imapclient-0.12.ebuild
deleted file mode 100644 (file)
index 8c024c4..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} pypy )
-
-inherit distutils-r1
-
-MY_PN="IMAPClient"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="easy-to-use, pythonic, and complete IMAP client library"
-HOMEPAGE="http://imapclient.freshfoo.com/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc examples test"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy) )"
-
-S=${WORKDIR}/${MY_P}
-
-python_prepare_all() {
-       # use system setuptools
-       sed -i '/use_setuptools/d' setup.py || die
-
-       # drop explicit mock version test dep
-       sed -i "/tests_require/s:'mock==.\+':'mock':" setup.py || die
-
-       # use system six library. patch proven less preferable to use of sed (< maintenance)
-       # but a copy of the working hunks from prior version works fine for now.
-       rm imapclient/six.py || die
-       epatch "${FILESDIR}"/0.12-tests.patch
-       sed -e 's:from .six:from six:g' \
-               -e 's:from . import six:import six:g' \
-               -i ${PN}/*.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       "${PYTHON}" -m unittest discover || die "tests failed under ${EPYTHON}"
-}
-
-python_install() {
-       distutils-r1_python_install
-       # don't install examples and tests in module dir
-       rm -r "${D}"$(python_get_sitedir)/imapclient/{examples,test} || die
-}
-
-python_install_all() {
-#      local DOCS=( AUTHORS HACKING.rst NEWS.rst README.rst THANKS )
-       use doc && local HTML_DOCS=( doc/html/. )
-       distutils-r1_python_install_all
-       use examples && dodoc -r ${PN}/examples
-}