dev-lang/qu-prolog: version bump
authorKeri Harris <keri@gentoo.org>
Wed, 27 May 2020 16:02:27 +0000 (18:02 +0200)
committerKeri Harris <keri@gentoo.org>
Wed, 27 May 2020 16:03:10 +0000 (18:03 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Keri Harris <keri@gentoo.org>
dev-lang/qu-prolog/Manifest
dev-lang/qu-prolog/qu-prolog-10.3.ebuild [new file with mode: 0644]

index e08b211f2c66b0723db42cf883dbbe86c80fd4bf..40dbbfce6ebe1922d737e7a8046d23692341f31c 100644 (file)
@@ -1,2 +1,3 @@
 DIST qp10.1.tar.gz 1521610 BLAKE2B a4d6d277a35284accfff1afd70901218df198b2b33f5c95ca5649bf06abcb153890f2f21b0e8d62ed93484b452a230074f93c983ab231c8fc58b51a29119d838 SHA512 8fb30fcbc086384d7e265695a7d24a9599ed306b5da0ea964e60aef4bb01c7b6789fc361449f908736c57d86c204e574d745f277d5b0ec2b725a8eca52f14f1a
 DIST qp10.2.tar.gz 1667066 BLAKE2B fe466bc892a0923f463347bfa22618061d8a8baf9e2fc60ea27694c66be6dc8ac9b0bacd3084bccff95ff06ef949660cb9a0637a8e3e3595d04c44eb2b682bc9 SHA512 5cfebab17a812513bb4ddf4c04890af32339bef18d746dd6503cee13d295c43f1ef687a6c7814b2f40473766c695459f8234541ae8a6945a0f2930556985ad96
+DIST qp10.3.tar.gz 1669345 BLAKE2B 9dc14f683555b22e7bb2119dd6d29cad7c934bb162def4358d69da65cd259b586fac593c7770dc1d665ab56da2e1129a696e84b01a271b747a9e3a8598c0d7fa SHA512 e28519fccf58f2b755382f2b8e56c15f2622508822c920975577feb6b837f96346a14eb23a5209ed126e617264ed7846b8a35d5936e99284503d5c435c0a1c18
diff --git a/dev-lang/qu-prolog/qu-prolog-10.3.ebuild b/dev-lang/qu-prolog/qu-prolog-10.3.ebuild
new file mode 100644 (file)
index 0000000..9f9d19a
--- /dev/null
@@ -0,0 +1,99 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils multilib qmake-utils
+
+MY_P=qp${PV}
+
+DESCRIPTION="Extended Prolog supporting quantifiers, object-variables and substitutions"
+HOMEPAGE="http://www.itee.uq.edu.au/~pjr/HomePages/QuPrologHome.html"
+SRC_URI="http://www.itee.uq.edu.au/~pjr/HomePages/QPFiles/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug doc examples pedro qt5 readline threads"
+
+RDEPEND="
+       !dev-util/mpatch
+       !dev-util/rej
+       !games-rpg/kqlives
+       qt5? (
+               dev-qt/qtwidgets:5
+               dev-qt/qtgui:5
+        )
+       pedro? ( net-misc/pedro )
+       readline? ( app-misc/rlwrap )"
+DEPEND="${RDEPEND}
+       dev-lang/perl"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+       epatch "${FILESDIR}"/${PN}-10.x-qt5.patch
+
+       eapply_user
+}
+
+src_configure() {
+       econf \
+               --libdir=/usr/$(get_libdir) \
+               $(use_enable debug) \
+               $(use_enable threads multiple-threads)
+
+       if use qt5; then
+               cd "${S}"/src/xqp || die
+               eqmake5 xqp.pro
+       fi
+}
+
+src_compile() {
+       emake OPTIMISATION="${CXXFLAGS}"
+
+       if use qt5; then
+               cd "${S}"/src/xqp || die
+               emake
+       fi
+}
+
+src_install() {
+       sed \
+               -e "s|${S}|/usr/$(get_libdir)/qu-prolog|g" \
+               -i bin/qc bin/qc1.qup bin/qecat bin/qg bin/qp || die
+
+       dobin bin/{qc,qecat,qp,kq}
+
+       use qt5 && dobin src/xqp/xqp
+
+       into /usr/$(get_libdir)/${PN}
+       dobin bin/{qa,qc1.qup,qdeal,qem,qg,ql,qppp}
+
+       insinto /usr/$(get_libdir)/${PN}/bin
+       doins bin/rl_commands
+       doins bin/{qc1.qup,qecat,qg,qp}.qx
+
+       insinto /usr/$(get_libdir)/${PN}/library
+       doins prolog/library/*.qo
+
+       insinto /usr/$(get_libdir)/${PN}/compiler
+       doins prolog/compiler/*.qo
+
+       doman doc/man/man1/*.1
+
+       dodoc README
+
+       if use doc ; then
+               docinto reference-manual
+               dodoc doc/manual/*.html
+               docinto user-guide
+               dodoc doc/user/main.pdf
+       fi
+
+       if use examples ; then
+               docinto examples
+               newdoc examples/README README.examples
+               dodoc examples/*.ql
+       fi
+}