dev-python/testrepository: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sun, 29 Mar 2020 09:59:27 +0000 (11:59 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 29 Mar 2020 10:13:02 +0000 (12:13 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/testrepository/Manifest
dev-python/testrepository/files/testrepository-0.0.18-test-backport.patch [deleted file]
dev-python/testrepository/testrepository-0.0.18-r1.ebuild [deleted file]

index 7467dd1ed44dac212179caf9135622cdffd0f352..013694ad9220e511f72e74251f13ee49ea539cff 100644 (file)
@@ -1,2 +1 @@
-DIST testrepository-0.0.18.tar.gz 84886 BLAKE2B b6c0161c55271722644eddd5d620ea67b67774e92d2de0117f645fc1016c9de209de6a9557862a27e08850a3ade5a2406ea5eaa410a2ce4d44fc26c8121ddecf SHA512 4e90db6364f77f464ae063020b016367529588f581af001c2564bf4babb264fc37bb7231413725211c6d483a269360d86201f81d2b24d7eb162dca2463d13c92
 DIST testrepository-0.0.20.tar.gz 84956 BLAKE2B 9b9a8e0c21754fe8ba019b58024f137e72b4341cb368fb48dc48039f512b232ca4f03f16c2596aa34b428d69097db939e5776417a7d26f5a8508c8f0c1f1a5bf SHA512 df14500e2b27b6f39d9d4c4f42961efd63dfe25186e561eb1678952a8ab9311f17c36b78819fea33e0ac879c47a33d45c31ff58be017609c8a6157905ee712d6
diff --git a/dev-python/testrepository/files/testrepository-0.0.18-test-backport.patch b/dev-python/testrepository/files/testrepository-0.0.18-test-backport.patch
deleted file mode 100644 (file)
index 112b029..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-diff --git a/testrepository/tests/test_repository.py b/testrepository/tests/test_repository.py
-index e2e5e05..4a8667b 100644
---- a/testrepository/tests/test_repository.py
-+++ b/testrepository/tests/test_repository.py
-@@ -28,6 +28,7 @@
- from testresources import TestResource
- from testtools import (
-     clone_test_with_new_id,
-+    content,
-     PlaceHolder,
-     )
- import testtools
-@@ -103,19 +104,24 @@ class Case(ResourcedTestCase):
-     def passing(self):
-         pass
--    def failing(self):
--        self.fail("oops")
--
-     def unexpected_success(self):
-         self.expectFailure("unexpected success", self.assertTrue, True)
-+class FailingCase:
-+
-+    def run(self, result):
-+        result.startTest(self)
-+        result.addError(
-+            self, None, details={'traceback': content.text_content("")})
-+        result.stopTest(self)
-+
- def make_test(id, should_pass):
-     """Make a test."""
-     if should_pass:
-         case = Case("passing")
-     else:
--        case = Case("failing")
-+        case = FailingCase()
-     return clone_test_with_new_id(case, id)
diff --git a/dev-python/testrepository/testrepository-0.0.18-r1.ebuild b/dev-python/testrepository/testrepository-0.0.18-r1.ebuild
deleted file mode 100644 (file)
index 332e0dc..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="A repository of test results"
-HOMEPAGE="https://launchpad.net/testscenarios"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-python/subunit-0.0.10[${PYTHON_USEDEP}]
-       >=dev-python/testtools-0.9.30[${PYTHON_USEDEP}]
-       dev-python/fixtures[${PYTHON_USEDEP}]"
-#bzr is listed but presumably req'd for a live repo test run
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( ${RDEPEND}
-               dev-python/testresources[${PYTHON_USEDEP}]
-               dev-python/testscenarios[${PYTHON_USEDEP}]
-               dev-python/pytz[${PYTHON_USEDEP}]
-       )"
-
-# Required for test phase
-DISTUTILS_IN_SOURCE_BUILD=1
-
-PATCHES=(
-       "${FILESDIR}"/${P}-test-backport.patch
-       "${FILESDIR}"/${PN}-0.0.20-test-backport1.patch
-)
-
-python_test() {
-       # some errors appear to have crept in the suite undert py3 since addition.
-       # Python2.7 now passes all.
-
-       ${PYTHON} testr init || die
-       ${PYTHON} testr run || die
-}