sys-apps/systemd: make the ebuild compiler-agnostic
authorMike Gilbert <floppym@gentoo.org>
Fri, 18 Nov 2016 18:21:44 +0000 (13:21 -0500)
committerMike Gilbert <floppym@gentoo.org>
Fri, 18 Nov 2016 18:22:15 +0000 (13:22 -0500)
Remove binutils and gcc from depend. Remove gcc version check.
Pass --with-efi-libdir to workaround compilers which do not support the
-print-multi-os-directory option.

Note that gnu-efi headers still require gcc; EFI_CC can be set to gcc to work
around this.

Bug: https://bugs.gentoo.org/599210

Package-Manager: portage-2.3.2_p8

sys-apps/systemd/systemd-232.ebuild
sys-apps/systemd/systemd-9999.ebuild

index a45086f14ee9dfac3d2b7c81515310a27bd2dbb2..028d6865ad8156b5f732ee19552ef20ed02086f3 100644 (file)
@@ -86,8 +86,6 @@ DEPEND="${COMMON_DEPEND}
        dev-util/gperf
        >=dev-util/intltool-0.50
        >=sys-apps/coreutils-8.16
-       >=sys-devel/binutils-2.23.1
-       >=sys-devel/gcc-4.6
        >=sys-kernel/linux-headers-${MINKV}
        virtual/pkgconfig
        gnuefi? ( >=sys-boot/gnu-efi-3.0.2 )
@@ -124,16 +122,6 @@ pkg_pretend() {
                        fi
        fi
 
-       if [[ ${MERGE_TYPE} != binary ]]; then
-               if [[ $(gcc-major-version) -lt 4
-                       || ( $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ) ]]
-               then
-                       eerror "systemd requires at least gcc 4.6 to build. Please switch the active"
-                       eerror "gcc version using gcc-config."
-                       die "systemd requires at least gcc 4.6"
-               fi
-       fi
-
        if [[ ${MERGE_TYPE} != buildonly ]]; then
                if kernel_is -lt ${MINKV//./ }; then
                        ewarn "Kernel version at least ${MINKV} required"
@@ -231,6 +219,7 @@ multilib_src_configure() {
                $(multilib_native_use_enable elfutils)
                $(use_enable gcrypt)
                $(multilib_native_use_enable gnuefi)
+               --with-efi-libdir="/usr/$(get_libdir)"
                $(multilib_native_use_enable http microhttpd)
                $(usex http $(multilib_native_use_enable ssl gnutls) --disable-gnutls)
                $(multilib_native_use_enable idn libidn)
index a45086f14ee9dfac3d2b7c81515310a27bd2dbb2..028d6865ad8156b5f732ee19552ef20ed02086f3 100644 (file)
@@ -86,8 +86,6 @@ DEPEND="${COMMON_DEPEND}
        dev-util/gperf
        >=dev-util/intltool-0.50
        >=sys-apps/coreutils-8.16
-       >=sys-devel/binutils-2.23.1
-       >=sys-devel/gcc-4.6
        >=sys-kernel/linux-headers-${MINKV}
        virtual/pkgconfig
        gnuefi? ( >=sys-boot/gnu-efi-3.0.2 )
@@ -124,16 +122,6 @@ pkg_pretend() {
                        fi
        fi
 
-       if [[ ${MERGE_TYPE} != binary ]]; then
-               if [[ $(gcc-major-version) -lt 4
-                       || ( $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ) ]]
-               then
-                       eerror "systemd requires at least gcc 4.6 to build. Please switch the active"
-                       eerror "gcc version using gcc-config."
-                       die "systemd requires at least gcc 4.6"
-               fi
-       fi
-
        if [[ ${MERGE_TYPE} != buildonly ]]; then
                if kernel_is -lt ${MINKV//./ }; then
                        ewarn "Kernel version at least ${MINKV} required"
@@ -231,6 +219,7 @@ multilib_src_configure() {
                $(multilib_native_use_enable elfutils)
                $(use_enable gcrypt)
                $(multilib_native_use_enable gnuefi)
+               --with-efi-libdir="/usr/$(get_libdir)"
                $(multilib_native_use_enable http microhttpd)
                $(usex http $(multilib_native_use_enable ssl gnutls) --disable-gnutls)
                $(multilib_native_use_enable idn libidn)