dev-tcltk/vtcl: EAPI 7
authorTupone Alfredo <tupone@gentoo.org>
Sat, 12 Oct 2019 14:19:31 +0000 (16:19 +0200)
committerTupone Alfredo <tupone@gentoo.org>
Sat, 12 Oct 2019 14:19:31 +0000 (16:19 +0200)
Closes: https://bugs.gentoo.org/697338
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
dev-tcltk/vtcl/vtcl-1.6.0-r1.ebuild
dev-tcltk/vtcl/vtcl-1.6.0-r2.ebuild [new file with mode: 0644]

index 596e52294e4ec854aece652fc41aedb101286f21..6b09343c4210be648f36f736f78bd0dc2d4d83fa 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=0
@@ -11,6 +11,7 @@ SLOT="0"
 KEYWORDS="amd64 ppc x86"
 IUSE="doc"
 DEPEND="dev-lang/tk"
+RDEPEND="${DEPEND}"
 
 MY_DESTDIR=/usr/share/${PN}
 src_compile() {
diff --git a/dev-tcltk/vtcl/vtcl-1.6.0-r2.ebuild b/dev-tcltk/vtcl/vtcl-1.6.0-r2.ebuild
new file mode 100644 (file)
index 0000000..5080e7e
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Visual Tcl is a high-quality application development environment"
+HOMEPAGE="http://vtcl.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+DEPEND="dev-lang/tk:*"
+RDEPEND="${DEPEND}"
+
+MY_DESTDIR=/usr/share/${PN}
+
+src_compile() {
+       sed -i 's,^\(VTCL_HOME=\).*,\1'${MY_DESTDIR}',g' vtcl   || die "Path fixing failed."
+       sed -i 's,package require -exact Tk ,package require Tk ,' lib/tkcon.tcl || die "Tcl8.5 patch failed"
+}
+
+src_install() {
+       dodir ${MY_DESTDIR}
+       dobin vtcl
+       cp -r ./{demo,images,lib,sample,vtcl.tcl} "${D}/${MY_DESTDIR}" || die "Data installation failed."
+       if use doc; then
+               DOCS=( ChangeLog README doc/tutorial.txt )
+               HTML_DOCS=( doc/*html )
+       fi
+       einstalldocs
+}