Fix some X lockups with the new tdfx driver. (Bug #136123, Rick Sheppard,
authorJoshua Baergen <joshuabaergen@gentoo.org>
Sat, 17 Jun 2006 15:56:56 +0000 (15:56 +0000)
committerJoshua Baergen <joshuabaergen@gentoo.org>
Sat, 17 Jun 2006 15:56:56 +0000 (15:56 +0000)
thanks to Sok Ann Yap for finding the patch.)
Package-Manager: portage-2.1.1_pre1

x11-drivers/xf86-video-tdfx/ChangeLog
x11-drivers/xf86-video-tdfx/files/digest-xf86-video-tdfx-1.2.1-r1 [new file with mode: 0644]
x11-drivers/xf86-video-tdfx/files/tdfx_getsecs.patch [new file with mode: 0644]
x11-drivers/xf86-video-tdfx/xf86-video-tdfx-1.2.1-r1.ebuild [new file with mode: 0644]

index 66639c706abb4b9cdbaff06cd2c39a7fe4d6de0a..2a55b2e71ffce04734f18e0df7501e1d66755f76 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for x11-drivers/xf86-video-tdfx
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-tdfx/ChangeLog,v 1.19 2006/06/05 21:29:27 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-tdfx/ChangeLog,v 1.20 2006/06/17 15:56:56 joshuabaergen Exp $
+
+*xf86-video-tdfx-1.2.1-r1 (17 Jun 2006)
+
+  17 Jun 2006; Joshua Baergen <joshuabaergen@gentoo.org>
+  +files/tdfx_getsecs.patch, -xf86-video-tdfx-1.2.1.ebuild,
+  +xf86-video-tdfx-1.2.1-r1.ebuild:
+  Fix some X lockups with the new tdfx driver.  (Bug #136123, Rick Sheppard,
+  thanks to Sok Ann Yap for finding the patch.)
 
   05 Jun 2006; Diego Pettenò <flameeyes@gentoo.org>
   xf86-video-tdfx-1.2.1.ebuild:
diff --git a/x11-drivers/xf86-video-tdfx/files/digest-xf86-video-tdfx-1.2.1-r1 b/x11-drivers/xf86-video-tdfx/files/digest-xf86-video-tdfx-1.2.1-r1
new file mode 100644 (file)
index 0000000..29706ac
--- /dev/null
@@ -0,0 +1,6 @@
+MD5 1b8cfd2923836ee93eda69abe50dda04 x11-driver-patches-1.tar.bz2 389
+RMD160 0c57d4b235d83f3d7c46691c13857fd121ddec2d x11-driver-patches-1.tar.bz2 389
+SHA256 64787d5b57d2845c0fa9297a9d924093ba191fc3551798239d9983f0bcca9b3e x11-driver-patches-1.tar.bz2 389
+MD5 7513cf373d4ddbbf93651d9ae29ac7f3 xf86-video-tdfx-1.2.1.tar.bz2 269783
+RMD160 9d86f47b1eb5b921122a8c13d6e0335098fced3f xf86-video-tdfx-1.2.1.tar.bz2 269783
+SHA256 c237565a1703bdf01fa9208bf51439d2f36e9c586a5bf3f51ae0a39e8bf3959b xf86-video-tdfx-1.2.1.tar.bz2 269783
diff --git a/x11-drivers/xf86-video-tdfx/files/tdfx_getsecs.patch b/x11-drivers/xf86-video-tdfx/files/tdfx_getsecs.patch
new file mode 100644 (file)
index 0000000..e96b172
--- /dev/null
@@ -0,0 +1,35 @@
+--- xf86-video-tdfx-1.2.1/src/tdfx_priv.c.getsecs      2006-04-04 08:06:58.000000000 -0400
++++ xf86-video-tdfx-1.2.1/src/tdfx_priv.c      2006-06-07 13:36:32.000000000 -0400
+@@ -114,16 +114,16 @@
+   /* Toggle the reset bits */
+   oldValue=TDFXReadLongMMIO(pTDFX, MISCINIT0);
+   TDFXWriteLongMMIO(pTDFX, MISCINIT0, oldValue|0x23);
+-  getsecs(&start_sec, &dummy);
++  xf86getsecs(&start_sec, &dummy);
+   do {
+-    getsecs(&end_sec, &dummy);
++    xf86getsecs(&end_sec, &dummy);
+   } while (end_sec-start_sec<2);
+   TDFXWriteLongMMIO(pTDFX, MISCINIT0, oldValue);
+   oldValue=TDFXReadLongMMIO(pTDFX, MISCINIT1);
+   TDFXWriteLongMMIO(pTDFX, MISCINIT1, oldValue|BIT(19));
+-  getsecs(&start_sec, &dummy);
++  xf86getsecs(&start_sec, &dummy);
+   do {
+-    getsecs(&end_sec, &dummy);
++    xf86getsecs(&end_sec, &dummy);
+   } while (end_sec-start_sec<2);
+   TDFXWriteLongMMIO(pTDFX, MISCINIT1, oldValue);
+   InstallFifo(pScrn);
+@@ -158,9 +158,9 @@
+     cnt++;
+     if (cnt==1000) {
+       if (!start_sec) {
+-      getsecs(&start_sec, &dummy);
++      xf86getsecs(&start_sec, &dummy);
+       } else {
+-      getsecs(&end_sec, &dummy);
++      xf86getsecs(&end_sec, &dummy);
+       if (end_sec-start_sec>3) {
+         dummy=TDFXReadLongMMIO(pTDFX, SST_FIFO_RDPTRL0);
+         if (dummy==readptr) {
diff --git a/x11-drivers/xf86-video-tdfx/xf86-video-tdfx-1.2.1-r1.ebuild b/x11-drivers/xf86-video-tdfx/xf86-video-tdfx-1.2.1-r1.ebuild
new file mode 100644 (file)
index 0000000..e321f1d
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-tdfx/xf86-video-tdfx-1.2.1-r1.ebuild,v 1.1 2006/06/17 15:56:56 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org driver for tdfx cards"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="dri"
+RDEPEND=">=x11-base/xorg-server-1.0.99"
+DEPEND="${RDEPEND}
+       x11-proto/fontsproto
+       x11-proto/randrproto
+       x11-proto/renderproto
+       x11-proto/videoproto
+       x11-proto/xextproto
+       x11-proto/xproto
+       dri? ( x11-proto/xf86driproto
+                       >=x11-libs/libdrm-2 )"
+
+CONFIGURE_OPTIONS="$(use_enable dri)"
+PATCHES="${FILESDIR}/tdfx_getsecs.patch"
+
+pkg_setup() {
+       if use dri && ! built_with_use x11-base/xorg-server dri; then
+               die "Build x11-base/xorg-server with USE=dri."
+       fi
+}