app-emulation/protontricks: new package
authorMarek Szuba <marecki@gentoo.org>
Wed, 8 Jan 2020 13:34:17 +0000 (13:34 +0000)
committerMarek Szuba <marecki@gentoo.org>
Wed, 8 Jan 2020 13:36:27 +0000 (13:36 +0000)
Allows one to use winetricks on Proton (Steam Play) games without
having to manually mess with prefix and Proton configuration.

Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Marek Szuba <marecki@gentoo.org>
app-emulation/protontricks/Manifest [new file with mode: 0644]
app-emulation/protontricks/metadata.xml [new file with mode: 0644]
app-emulation/protontricks/protontricks-1.3.1.ebuild [new file with mode: 0644]

diff --git a/app-emulation/protontricks/Manifest b/app-emulation/protontricks/Manifest
new file mode 100644 (file)
index 0000000..a4be8ea
--- /dev/null
@@ -0,0 +1 @@
+DIST protontricks-1.3.1.tar.gz 57784 BLAKE2B ed013367a2cc2384e4340379e2c23999a556ed26920ad59dfd7a8f773e490ee76e253a5fe3216e651cdcdb3e225a2e394255500c611d24f6bf9029582d55bb1f SHA512 4e33334e219db2e6679b430ee42408529478834c80c7da3b9bece4756eb27b9331d49a6a884de8a7ced5ec29d78ce831fee4cfbf6d5adcd750666b7e7a1e5607
diff --git a/app-emulation/protontricks/metadata.xml b/app-emulation/protontricks/metadata.xml
new file mode 100644 (file)
index 0000000..23f787c
--- /dev/null
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>marecki@gentoo.org</email>
+               <name>Marek Szuba</name>
+       </maintainer>
+       <longdescription lang="en">
+               A simple wrapper script that allows you to easily run Winetricks commands for Steam Play/Proton
+               games. This is often useful when a game requires closed-source runtime libraries that are not
+               included with Proton, or to activate Gallium Nine (native Direct3D 9 support) for a Proton game,
+               without all the tedious messing around with Wine prefixes.
+       </longdescription>
+       <use>
+               <flag name="gui">Enable the graphical user interface (requires <pkg>gnome-extra/zenity</pkg>)</flag>
+       </use>
+       <upstream>
+               <remote-id type="github">Matoking/protontricks</remote-id>
+               <remote-id type="pypi">protontricks</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/app-emulation/protontricks/protontricks-1.3.1.ebuild b/app-emulation/protontricks/protontricks-1.3.1.ebuild
new file mode 100644 (file)
index 0000000..0b0e576
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_SINGLE_IMPL=1
+inherit distutils-r1
+
+DESCRIPTION="app-emulation/winetricks wrapper for Proton (Steam Play) games"
+HOMEPAGE="https://github.com/Matoking/protontricks"
+SRC_URI="https://codeload.github.com/Matoking/${PN}/tar.gz/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gui"
+
+RDEPEND="${PYTHON_DEPS}
+       app-emulation/winetricks
+       dev-python/vdf[${PYTHON_USEDEP}]
+       gui? ( gnome-extra/zenity
+               || (
+                       app-emulation/winetricks[gtk]
+                       app-emulation/winetricks[kde]
+               )
+       )"
+
+DOCS=(CHANGELOG.md README.md)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+       elog
+
+       if ! use gui; then
+               ewarn "Please note that disabling USE=gui does *not* presently remove the --gui command-line option,"
+               ewarn "it just means using this option will fail unless gnome-extra/zenity happens to be installed."
+               ewarn
+       fi
+
+       elog "Protontricks can only find games for which a Proton prefix already exists."
+       elog "Make sure to run a Proton game at least once before trying to use protontricks on it."
+       elog
+}