dev-python/mock: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 11 May 2020 17:19:32 +0000 (19:19 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 11 May 2020 17:33:11 +0000 (19:33 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/mock/Manifest
dev-python/mock/mock-2.0.0.ebuild [deleted file]

index a2fd44f263c505e9bf588b9005346de11c262a9b..503c3dd656446ead86a012de4ea51a69abfbb5f4 100644 (file)
@@ -1,2 +1 @@
-DIST mock-2.0.0.tar.gz 73684 BLAKE2B 970bebe72b6969b58acdc2856b53054f992d01f9f3ca5f91b73073d0a1c9ec89a5c94fd66eab85b258f23f33326825ff6598bb2ba8e07eded1e6540a26ac5fa3 SHA512 a08007651b749d2843b94f5045d74c122958888290aea21930455538a854e6b04c07115e21d82edde996154bf597d7a8784a2f4213cbabc49a98dec22dd92238
 DIST mock-3.0.5.gh.tar.gz 67887 BLAKE2B b9c49b3627275889d73aff9ea9c7925093f9cafb304448b2f06eda2fff26152a031aafb4844537e4d58bc112709e59a44e08d32602776386a30d039743def29c SHA512 9ab4f0c794f5701ba1367d982cf79a5662d4233753d12ed9c88ae20282db1f44be73f84c4d9f6d03ff64926b8c1b6d0c9a79b2a4724a3eb36c247ffd4ab03e2d
diff --git a/dev-python/mock/mock-2.0.0.ebuild b/dev-python/mock/mock-2.0.0.ebuild
deleted file mode 100644 (file)
index 4e68121..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Rolling backport of unittest.mock for all Pythons"
-HOMEPAGE="https://github.com/testing-cabal/mock"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-CDEPEND="
-       >=dev-python/pbr-1.3[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep '
-               dev-python/funcsigs[${PYTHON_USEDEP}]
-       ' -2)"
-DEPEND="
-       >=dev-python/setuptools-17.1[${PYTHON_USEDEP}]
-       test? (
-               ${CDEPEND}
-               dev-python/nose[${PYTHON_USEDEP}]
-               >=dev-python/unittest2-1.1.0[${PYTHON_USEDEP}]
-       )"
-RDEPEND="
-       ${CDEPEND}
-       >=dev-python/six-1.9[${PYTHON_USEDEP}]
-"
-
-python_test() {
-       nosetests --verbose || die "tests fail under ${EPYTHON}"
-}
-
-python_install_all() {
-       local DOCS=( docs/{conf.py,index.txt} AUTHORS ChangeLog NEWS README.rst )
-
-       distutils-r1_python_install_all
-}