dev-python/python-ethtool: version bump (0.14)
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>
Sat, 2 Feb 2019 20:57:56 +0000 (21:57 +0100)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Sat, 2 Feb 2019 23:42:19 +0000 (15:42 -0800)
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com>
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
dev-python/python-ethtool/Manifest
dev-python/python-ethtool/python-ethtool-0.14.ebuild [new file with mode: 0644]

index b472e3a2229f069cb189282da399adf3e16e2bad..dd7f489df1238da2d55ac62011c2ccb4208546c2 100644 (file)
@@ -1,2 +1,3 @@
 DIST python-ethtool-0.11.tar.bz2 34487 BLAKE2B bdb5eced32c508a593bbbc80fc287ece547c34504bbdf36877f4b62dea1239a33c5ea23dcecdd8b0f8104eea3ec7d5418a3ee5a1697930ea24a51da42f3ddc24 SHA512 b260e608e1024c48eedb72327b704b01fb42396219ca3d942fe42f22d3e8018fc74bfeffd96e37abd4efd2ce49a73915e0e2af5841a537a02e247d4ba5548f20
 DIST python-ethtool-0.11.tar.gz 37326 BLAKE2B b2345f5aece60c3b418d9fcd61220ab77fb49b9995a23b0ed6d97135dee61e4ffa177059869a8702430703b9f6518ffdcb8d690c868d0f8338ab16fdc36c58ea SHA512 227a9248dfdd36a9018a441d3ef4680691c23dac52972fe1ecc67ff30991f3de4cd71af0e48669ca382d6f177d1b3ebc97596e5a5ae4b4c80371456effe637b5
+DIST python-ethtool-0.14.tar.gz 41945 BLAKE2B d83e40e79481ee5f91f7e097dc4f6f0eb541f88ba83e13c13b3129ece2196ee999f9110310339ebbc2343b814a3b2c80405a3b4ce6931110509a54281b370cd8 SHA512 57a3f2d60dd8309192fc858614645d4e7533c90c03113ffc1eeeb810b86eb71b0a80b4eb209d3452c7624c5318a853de50d9d716d41334bf079e6e3e2490fd4b
diff --git a/dev-python/python-ethtool/python-ethtool-0.14.ebuild b/dev-python/python-ethtool/python-ethtool-0.14.ebuild
new file mode 100644 (file)
index 0000000..7da6d37
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+# TODO: install scripts and their man pages
+
+inherit distutils-r1
+
+DESCRIPTION="Ethernet settings python bindings"
+HOMEPAGE="https://pypi.org/project/ethtool/
+       https://github.com/fedora-python/python-ethtool"
+SRC_URI="https://github.com/fedora-python/python-ethtool/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64"
+
+DEPEND="dev-libs/libnl:3"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"