app-emacs/apel: Fix brace issue, EAPI 6
authorErik Mackdanz <stasibear@gentoo.org>
Sat, 28 Jul 2018 01:49:56 +0000 (20:49 -0500)
committerErik Mackdanz <stasibear@gentoo.org>
Sat, 28 Jul 2018 01:49:56 +0000 (20:49 -0500)
Closes: https://bugs.gentoo.org/647744
Package-Manager: Portage-2.3.43, Repoman-2.3.10

app-emacs/apel/apel-10.8-r1.ebuild
app-emacs/apel/files/apel-10.8-050_escape-backslash.patch [new file with mode: 0644]

index 7559be4d453d432d23def47b228a23781b8a73b0..8fbddf334241cc95930e25dece31a661f98fcf5e 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=6
 
 inherit elisp
 
@@ -18,7 +18,8 @@ IUSE=""
 ELISP_PATCHES="${PN}-10.8-020_Prevent-fontset-error.patch
        ${PN}-10.8-030_Use-new-style-backquotes.patch
        ${PN}-10.8-010_ikazuhiro.patch
-       ${PN}-10.8-040_make-temp-file-for-Emacs-24.3.50.patch"
+       ${PN}-10.8-040_make-temp-file-for-Emacs-24.3.50.patch
+       ${PN}-10.8-050_escape-backslash.patch"
 
 src_prepare() {
        elisp_src_prepare
diff --git a/app-emacs/apel/files/apel-10.8-050_escape-backslash.patch b/app-emacs/apel/files/apel-10.8-050_escape-backslash.patch
new file mode 100644 (file)
index 0000000..a2892d3
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/poe.el   2018-07-27 19:34:05.959194677 -0500
++++ b/poe.el   2018-07-27 19:40:06.409212629 -0500
+@@ -1081,7 +1081,7 @@
+ If third arg LITERAL is non-nil, insert NEWTEXT literally.
+ Otherwise treat `\' as special:
+   `\&' in NEWTEXT means substitute original matched text.
+-  `\N' means substitute what matched the Nth `\(...\)'.
++  `\\N' means substitute what matched the Nth `\(...\)'.
+        If Nth parens didn't match, substitute nothing.
+   `\\' means insert one `\'.
+ FIXEDCASE and LITERAL are optional arguments.
+@@ -1133,7 +1133,7 @@
+ If third arg LITERAL is non-nil, insert NEWTEXT literally.
+ Otherwise treat `\' as special:
+   `\&' in NEWTEXT means substitute original matched text.
+-  `\N' means substitute what matched the Nth `\(...\)'.
++  `\\N' means substitute what matched the Nth `\(...\)'.
+        If Nth parens didn't match, substitute nothing.
+   `\\' means insert one `\'.
+ FIXEDCASE and LITERAL are optional arguments.