dev-util/wstool: Remove old
authorDavid Seifert <soap@gentoo.org>
Sun, 29 Dec 2019 08:53:05 +0000 (09:53 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 29 Dec 2019 08:53:05 +0000 (09:53 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-util/wstool/Manifest
dev-util/wstool/files/prefix2.patch [deleted file]
dev-util/wstool/wstool-0.1.13.ebuild [deleted file]
dev-util/wstool/wstool-0.1.17.ebuild [deleted file]

index 235a4850546e0b689a315bd9b84420ccad0394a9..e04952ad72f19b2b398af7989de83c0434369270 100644 (file)
@@ -1,3 +1 @@
-DIST wstool-0.1.13.tar.gz 75188 BLAKE2B 6a34aa04e4a076a75dacf24faf789d5295f6ad9afbbdddae480d8cdd11db63940faeca2c5936a2432aeccae5274e2e9e4e824f303460fe96f95c0d17abeeb9c1 SHA512 4d54f78ca044d31d927de1c3387536d0447ece77672c555845adf54e47f07adb67e6e9c866bc2719aae468aeeb26c900b3784e0ec7cf014c8118e841a92dca14
-DIST wstool-0.1.17.tar.gz 76168 BLAKE2B 4862df0ff16a5102e42d3ed683dbd9e8eb432aaf44f6e641fba6bb6f5d962645685b0fc9ca11f3c8adbe15dbef33086b93e3f9136073f7f181b5da37522e28fa SHA512 13533354a40723137baadc125425a2ec3d6a441da4870f04a9e17c53509ee4d3dc27df1a59edc2c3985a05fbd66a045539e9814f73509ee527fb763f8a804626
 DIST wstool-0.1.18.tar.gz 80595 BLAKE2B ed90fc5c63ab5d775dfb49ddacc6da6e285aeb5078cf471c0d504659a9e322fde27797e4d05fd56dff4b9958558200cf05e46cf7ae71fd1231ab63048e668808 SHA512 fda9c679183c605048ed024a57b07fd2d9b644978a3e4ff89c3716b74d8e4ba0124779bcdf88a75fdbbf47c765b7ab63db7c84a55a6e1744fc6f955649590c48
diff --git a/dev-util/wstool/files/prefix2.patch b/dev-util/wstool/files/prefix2.patch
deleted file mode 100644 (file)
index 934443f..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: wstool-0.1.13/setup.py
-===================================================================
---- wstool-0.1.13.orig/setup.py
-+++ wstool-0.1.13/setup.py
-@@ -26,18 +26,11 @@ def _resolve_prefix(prefix, type):
-     # issue: https://github.com/vcstools/wstool/issues/81
-     osx_system_prefix = '/System/Library/Frameworks/Python.framework/Versions'
-     if type == 'man':
--        if prefix == '/usr':
--            return '/usr/share'
--        if sys.prefix.startswith(osx_system_prefix):
--            return '/usr/local/share'
-+        return os.path.join(prefix, 'share')
-     elif type == 'bash_comp':
--        if prefix == '/usr':
--            return '/'
--        if sys.prefix.startswith(osx_system_prefix):
--            return '/usr/local'
-+        return os.path.join(prefix, '../')
-     elif type == 'zsh_comp':
--        if sys.prefix.startswith(osx_system_prefix):
--            return '/usr/local'
-+        return os.path.join(prefix, '../')
-     else:
-         raise ValueError('not supported type')
-     return prefix
diff --git a/dev-util/wstool/wstool-0.1.13.ebuild b/dev-util/wstool/wstool-0.1.13.ebuild
deleted file mode 100644 (file)
index 30a7bd5..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_5} )
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
-       SCM="git-r3"
-       EGIT_REPO_URI="https://github.com/vcstools/wstool"
-fi
-
-inherit ${SCM} distutils-r1
-
-DESCRIPTION="Commands to manage several local SCM repositories for ROS"
-HOMEPAGE="http://wiki.ros.org/wstool"
-if [ "${PV#9999}" != "${PV}" ] ; then
-       SRC_URI=""
-       KEYWORDS=""
-else
-       SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
-               https://github.com/vcstools/wstool/archive/${PV}.tar.gz -> ${P}.tar.gz
-       "
-       KEYWORDS="~amd64 ~arm"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/pyyaml[${PYTHON_USEDEP}]
-       >=dev-python/vcstools-0.1.38[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
-       dev-python/sphinx
-       test? (
-               dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/coverage[${PYTHON_USEDEP}]
-               dev-vcs/git
-               dev-vcs/bzr
-               dev-vcs/mercurial
-               dev-vcs/subversion
-       )
-"
-
-PATCHES=( "${FILESDIR}/prefix2.patch" )
-DISTUTILS_IN_SOURCE_BUILD="yes"
-
-python_test() {
-       # From travis.yml
-       # Set git config to silence some stuff in the tests
-       git config --global user.email "foo@example.com"
-       git config --global user.name "Foo Bar"
-       # Set the hg user
-       echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
-       # Set the bzr user
-       bzr whoami "Your Name <name@example.com>"
-       # command to run tests
-       nosetests --with-coverage --cover-package=wstool || die
-}
diff --git a/dev-util/wstool/wstool-0.1.17.ebuild b/dev-util/wstool/wstool-0.1.17.ebuild
deleted file mode 100644 (file)
index 44cd350..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
-       SCM="git-r3"
-       EGIT_REPO_URI="https://github.com/vcstools/wstool"
-fi
-
-inherit ${SCM} distutils-r1
-
-DESCRIPTION="Commands to manage several local SCM repositories for ROS"
-HOMEPAGE="http://wiki.ros.org/wstool"
-if [ "${PV#9999}" != "${PV}" ] ; then
-       SRC_URI=""
-       KEYWORDS=""
-else
-       SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
-               https://github.com/vcstools/wstool/archive/${PV}.tar.gz -> ${P}.tar.gz
-       "
-       KEYWORDS="~amd64 ~arm"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/pyyaml[${PYTHON_USEDEP}]
-       >=dev-python/vcstools-0.1.38[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
-       dev-python/sphinx
-       test? (
-               dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/coverage[${PYTHON_USEDEP}]
-               dev-vcs/git
-               dev-vcs/bzr
-               dev-vcs/mercurial
-               dev-vcs/subversion
-       )
-"
-
-PATCHES=( "${FILESDIR}/prefix2.patch" )
-DISTUTILS_IN_SOURCE_BUILD="yes"
-
-python_test() {
-       # From travis.yml
-       # Set git config to silence some stuff in the tests
-       git config --global user.email "foo@example.com"
-       git config --global user.name "Foo Bar"
-       # Set the hg user
-       echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
-       # Set the bzr user
-       bzr whoami "Your Name <name@example.com>"
-       # command to run tests
-       nosetests --with-coverage --cover-package=wstool || die
-}