dev-python/treq: Version bump, adds python-3.7,3.8
authorBrian Dolbec <dolsen@gentoo.org>
Tue, 12 May 2020 08:31:31 +0000 (01:31 -0700)
committerBrian Dolbec <dolsen@gentoo.org>
Tue, 12 May 2020 18:15:02 +0000 (11:15 -0700)
metadata.xml: take maintainership
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
dev-python/treq/Manifest
dev-python/treq/metadata.xml
dev-python/treq/treq-20.4.1.ebuild [new file with mode: 0644]

index b1a246e44b5911fef36e6fe2ead00f9c706aea17..40dbbb70c9503c9632c5b9b3f5e762ff018be3a4 100644 (file)
@@ -1 +1,2 @@
 DIST treq-17.8.0.tar.gz 56439 BLAKE2B 3e39c84453793baf3107c38b656c8968e593845fc0d41035b558326ff947a9e17903ce33dee3157d2cb2f79ab3aa884ddebcd52e743cd6e1ad08a0de324cd6bc SHA512 62933a512fcc8b0e77333eb9268846ad17f4b44cf6ea317ada2565054100be3caf03bda0a1becd775ec85528fc2f5ddec33d23d3579cf484a3c6ba7c71c50a7f
+DIST treq-20.4.1.tar.gz 59116 BLAKE2B 1370748d8bde407a8802d54786b45fbbc65525efba14cd5a33d741573b9fca7b36629deea65672669c4da45347bb40d975a063430ffd18f50d5ef896ce6dae66 SHA512 ca24ca7ad6bcf3fe6cba490d05eea4d71727a84bb2caf0a019edc01f91f7c25d87dc8208fc7cc816d18ef42db4dc66884475f0baa6b2cf39714e4422d0d67d3b
index aa757fcc3d30d326bf48c386f16ad446366e4129..d90ac85b2d47b47f92983d239003341f922bbcaf 100644 (file)
@@ -1,7 +1,10 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-       <!-- maintainer-needed -->
+       <maintainer type="person">
+               <email>dolsen@gentoo.org</email>
+               <name>Brian Dolbec</name>
+       </maintainer>
        <upstream>
                <maintainer>
                        <email>hawkowl@twistedmatrix.com</email>
diff --git a/dev-python/treq/treq-20.4.1.ebuild b/dev-python/treq/treq-20.4.1.ebuild
new file mode 100644 (file)
index 0000000..ad0130f
--- /dev/null
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="A requests-like API built on top of twisted.web's Agent"
+HOMEPAGE="https://github.com/twisted/treq https://pypi.org/project/treq/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+       dev-python/incremental[${PYTHON_USEDEP}]
+       dev-python/hyperlink[${PYTHON_USEDEP}]
+"
+
+RDEPEND="${COMMON_DEPEND}
+       dev-python/six[${PYTHON_USEDEP}]
+       >=dev-python/twisted-18.7.0[crypt,${PYTHON_USEDEP}]
+       >=dev-python/requests-2.1.0[${PYTHON_USEDEP}]
+       dev-python/attrs[${PYTHON_USEDEP}]
+"
+
+DEPEND="${COMMON_DEPEND}
+       doc? ( dev-python/sphinx
+               ${RDEPEND} )
+       test? (
+               dev-python/mock[${PYTHON_USEDEP}]
+               dev-python/httpbin[${PYTHON_USEDEP}]
+       )"
+
+python_compile_all() {
+       use doc && emake -C "${S}/docs" html
+}
+
+python_install_all() {
+       use doc && dohtml -r "${S}/docs/_build/html/"*
+       distutils-r1_python_install_all
+}
+
+test_instructions(){
+       ewarn "The 'test' USE flag and FEATURE only ensures that the correct"
+       ewarn "dependenciess are installed for this package."
+       ewarn "Please run eg:"
+       ewarn "$ python3.7 /usr/bin/trial treq"
+       ewarn "as a user for each of the python versions it is installed to"
+       ewarn "to correctly test this package."
+}
+
+python_test() {
+       # Tests fail when run via emerge
+       # they need proper network access
+       test_instructions
+}