sys-boot/milo: Port to EAPI=7
authorMatt Turner <mattst88@gentoo.org>
Wed, 13 Nov 2019 06:51:12 +0000 (22:51 -0800)
committerMatt Turner <mattst88@gentoo.org>
Wed, 13 Nov 2019 06:53:14 +0000 (22:53 -0800)
Closes: https://bugs.gentoo.org/697180
Signed-off-by: Matt Turner <mattst88@gentoo.org>
sys-boot/milo/milo-2.4.18.ebuild

index 3902314970fbc0823ff7cb0dc3dc36321d4d0b81..e6bee2b3f6c643553b179976a10fddccb78cd192 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
 inherit flag-o-matic eutils
 
@@ -87,12 +87,16 @@ src_unpack() {
        # unpack everything the kernel and milo sources
        unpack linux-${kernel_version}.tar.bz2
        unpack milo-${milo_version}.tar.bz2
+       unpack linux-2.2.20-reiserfs-3.5.35.diff.bz2
+}
 
+src_prepare() {
        # gcc3 fixes, and some tweaks to get a build, also
        # reiserfs support for the kernel (and milo).
-       cd ${WORKDIR}/linux; epatch "${FILESDIR}"/linux-${kernel_version}-gcc3-milo.diff || die
-       cd ${WORKDIR}/linux; epatch "${DISTDIR}"/linux-2.2.20-reiserfs-3.5.35.diff.bz2 || die
-       cd ${S}; epatch "${FILESDIR}"/milo-${milo_version}-gcc3-gentoo.diff || die
+       cd ${WORKDIR}/linux; eapply "${FILESDIR}"/linux-${kernel_version}-gcc3-milo.diff || die
+       cd ${WORKDIR}/linux; eapply "${WORKDIR}"/linux-2.2.20-reiserfs-3.5.35.diff || die
+       cd ${S}; eapply "${FILESDIR}"/milo-${milo_version}-gcc3-gentoo.diff || die
+       eapply_user
 }
 
 src_compile() {
@@ -149,9 +153,6 @@ src_compile() {
        einfo "i will use it instead of the default."
        ewarn
 
-       einfon "continuing in 10 seconds ..."
-       epause 10
-
        # get kernel configured
        cp ${custom_milo_kernel_config:-${S}/Documentation/config/linux-2.2.19-SuSE.config} \
                ${WORKDIR}/linux/.config