dev-libs/libmateweather: Version bump (v1.22.0)
authorMikle Kolyada <zlogene@gentoo.org>
Sun, 17 Mar 2019 21:11:13 +0000 (00:11 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Sun, 17 Mar 2019 21:11:30 +0000 (00:11 +0300)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

dev-libs/libmateweather/Manifest
dev-libs/libmateweather/libmateweather-1.22.0.ebuild [new file with mode: 0644]

index 2ee896571c0aef0923a4b93874d363a1fcd2a79d..2b88023a24c6b660529170b6efeb7d84a2e9a53a 100644 (file)
@@ -1 +1,2 @@
 DIST libmateweather-1.18.2.tar.xz 3455940 BLAKE2B 15cb57c0202c1117f203bd9550c86d255404984e9163a7f79b8f81a0c436ff6bf9e1945536a15078ad479c9379798966337b6b8851ec84384ccc08c352d06260 SHA512 9b0f9b11f0c9b472a13adc1cfd26076dffd278e0154efa4248f8cc4a999250c88c761985b9a18978a7581e5459232fe2314181ae26a1c7c4fd4c80b536827504
+DIST libmateweather-1.22.0.tar.xz 3386920 BLAKE2B 312bd8cd12a1d51216b9509b2badaccb23779f1c7c314ecf02c9789837fa619d6029e97bf06f9fd320ba590936888d51fe178cffbb7dca87eb167ed4fbf3eabb SHA512 43371fc615dda2b9042633a63ac4c1fb0b1ea43b20c783e443b0f57e10ad8fddedbd593f03bd6c942729f0a9c80484266fe1ef900d128fa4b02f80d6a80ae9bd
diff --git a/dev-libs/libmateweather/libmateweather-1.22.0.ebuild b/dev-libs/libmateweather/libmateweather-1.22.0.ebuild
new file mode 100644 (file)
index 0000000..b18cfad
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+       KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="MATE library to access weather information from online services"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="debug"
+
+COMMON_DEPEND=">=dev-libs/glib-2.36:2
+       >=dev-libs/libxml2-2.6:2
+       >=net-libs/libsoup-2.34:2.4
+       >=sys-libs/timezone-data-2010k:0
+       x11-libs/gdk-pixbuf:2
+       virtual/libintl:0
+       >=x11-libs/gtk+-3.0:3"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+       dev-util/gtk-doc
+       dev-util/gtk-doc-am
+       >=dev-util/intltool-0.50.1:*
+       sys-devel/gettext:*
+       >=sys-devel/libtool-2.2.6:2
+       virtual/pkgconfig:*"
+
+src_configure() {
+       mate_src_configure \
+               --enable-locations-compression \
+               --disable-all-translations-in-one-xml \
+               --disable-icon-update
+}