acct-user/teamspeak: add user for media-sound/teamspeak-server
authorConrad Kostecki <conrad@kostecki.com>
Fri, 8 Nov 2019 08:49:00 +0000 (09:49 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Sat, 9 Nov 2019 07:52:04 +0000 (09:52 +0200)
UID 488 will be used, as its the next available.
Arch, Fedora and RHEL don't have a UID for this user.

Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
acct-user/teamspeak/metadata.xml [new file with mode: 0644]
acct-user/teamspeak/teamspeak-0.ebuild [new file with mode: 0644]

diff --git a/acct-user/teamspeak/metadata.xml b/acct-user/teamspeak/metadata.xml
new file mode 100644 (file)
index 0000000..54d5423
--- /dev/null
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>ck+gentoo@bl4ckb0x.de</email>
+               <name>Conrad Kostecki</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/acct-user/teamspeak/teamspeak-0.ebuild b/acct-user/teamspeak/teamspeak-0.ebuild
new file mode 100644 (file)
index 0000000..d5fa883
--- /dev/null
@@ -0,0 +1,14 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-user
+
+DESCRIPTION="A user for the TeamSpeak server"
+
+ACCT_USER_GROUPS=( "teamspeak" )
+ACCT_USER_HOME="/opt/teamspeak3-server"
+ACCT_USER_ID="488"
+
+acct-user_add_deps