dev-libs/spdlog: Switch to cmake.eclass
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 2 Jan 2020 19:07:25 +0000 (20:07 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 2 Jan 2020 19:09:46 +0000 (20:09 +0100)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-libs/spdlog/spdlog-1.3.0.ebuild
dev-libs/spdlog/spdlog-1.3.1.ebuild
dev-libs/spdlog/spdlog-9999.ebuild

index d1e170a969e13a36c802cc851d937c9ee7c8f881..f6cb54548b9bba9e309bc66ff39fe2fff9cb427a 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-inherit cmake-utils
+inherit cmake
 
 DESCRIPTION="Very fast, header only, C++ logging library"
 HOMEPAGE="https://github.com/gabime/spdlog"
@@ -37,5 +37,5 @@ src_configure() {
                -DSPDLOG_BUILD_TESTS=$(usex test)
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
index ddf07aa21ca6b55552c4b9315a2ae93b7013140f..69ab5a2e653a01d053fe371aa2a9fb6ae2f1c546 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-inherit cmake-utils
+inherit cmake
 
 DESCRIPTION="Very fast, header only, C++ logging library"
 HOMEPAGE="https://github.com/gabime/spdlog"
@@ -37,5 +37,5 @@ src_configure() {
                -DSPDLOG_BUILD_TESTS=$(usex test)
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
index 3381d35fd4b5177a487e6018b3c0b2c96e32772a..f0b80109ac4a4a873440363e99b922b2ef764732 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-inherit cmake-utils
+inherit cmake
 
 DESCRIPTION="Very fast, header only, C++ logging library"
 HOMEPAGE="https://github.com/gabime/spdlog"
@@ -37,5 +37,5 @@ src_configure() {
                -DSPDLOG_BUILD_TESTS=$(usex test)
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }