sys-libs/db: Move CXXFLAGS alteration to local scope
authorJustin Lecher <jlec@gentoo.org>
Wed, 2 Sep 2015 16:25:24 +0000 (18:25 +0200)
committerJustin Lecher <jlec@gentoo.org>
Wed, 2 Sep 2015 16:30:36 +0000 (18:30 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
sys-libs/db/db-3.2.9_p2.ebuild
sys-libs/db/metadata.xml

index 06df0546aa1dbdffa6f0c39ea33dbad42249a3a4..65f1809ddf134a47888acb615333334e359569d2 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -33,12 +33,12 @@ IUSE="doc"
 DEPEND="${RDEPEND}
        =sys-libs/db-1.85*"
 
-# This doesn't build without exceptions
-export CXXFLAGS="${CXXFLAGS/-fno-exceptions/-fexceptions}"
-
 S="${WORKDIR}/${MY_P}"
 
 src_unpack() {
+       # This doesn't build without exceptions
+       export CXXFLAGS="${CXXFLAGS/-fno-exceptions/-fexceptions}"
+
        unpack "${MY_P}".tar.gz
 
        chmod -R ug+w *
index 74fb0c9417a7bd994be68dbba13ab8c56882fc64..0f33890bd253317d8758a9b39afffada60f7a46a 100644 (file)
@@ -1,23 +1,22 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-<herd>base-system</herd>
-<longdescription>The Berkeley Database (Berkeley DB) is a programmatic toolkit
+       <herd>base-system</herd>
+       <longdescription>The Berkeley Database (Berkeley DB) is a programmatic toolkit
 that provides embedded database support for both traditional and client/server
 applications. Berkeley DB includes b+tree, queue, extended linear hashing,
 fixed, and variable-length record access methods, transactions, locking,
 logging, shared memory caching and database recovery. DB supports C, C++, Java,
 and Perl APIs. DB is available for a wide variety of UNIX platforms as well as
 Windows NT and Windows '95 (MSVC 4, 5 and 6).</longdescription>
-<longdescription lang="nl">De Berkeley Database is een programmatische toolkit
+       <longdescription lang="nl">De Berkeley Database is een programmatische toolkit
 die embedded database support verzorg voor en traditionele en client/server
 applicaties. Berkeley DB bevat b+tree, rij, uitgebreide lineaire hashing, vaste
 en variabele lengte record toegangsmethoden, transacties, locking, logging,
 gedeeld geheugen caching en database herstel. DB ondersteund C, C++, Java en
 Perl API's. DB is beschikbaar voor veel UNIX platformen en
 Windows.</longdescription>
-<use>
<flag name='rpc'>Enable rpc client/server</flag>
-</use>
+       <use>
              <flag name="rpc">Enable rpc client/server</flag>
+       </use>
 </pkgmetadata>
-