Fix broken autotools handling.
authorDiego Elio Pettenò <flameeyes@gentoo.org>
Thu, 4 Jan 2007 15:22:18 +0000 (15:22 +0000)
committerDiego Elio Pettenò <flameeyes@gentoo.org>
Thu, 4 Jan 2007 15:22:18 +0000 (15:22 +0000)
Package-Manager: portage-2.1.2_rc4-r5

media-libs/libiec61883/ChangeLog
media-libs/libiec61883/libiec61883-1.1.0.ebuild
media-libs/tunepimp/ChangeLog
media-libs/tunepimp/tunepimp-0.5.2.ebuild

index 9378c9ad4b0ff544634c078a5bdba5b1b598ce3f..590f2a0f3afa959728e6d1bbdd779e4b14a61820 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for media-libs/libiec61883
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libiec61883/ChangeLog,v 1.16 2006/11/09 09:29:22 zzam Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libiec61883/ChangeLog,v 1.17 2007/01/04 15:22:18 flameeyes Exp $
+
+  04 Jan 2007; Diego Pettenò <flameeyes@gentoo.org>
+  libiec61883-1.1.0.ebuild:
+  Fix broken autotools handling.
 
   09 Nov 2006; Matthias Schwarzott <zzam@gentoo.org>
   libiec61883-1.0.0-r1.ebuild, libiec61883-1.1.0.ebuild:
index 7be67b0b01e2581171b2a84fdc4bae108fbe3071..294c4534ed36a6499f4b7a6981f904b5ee7ef028 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libiec61883/libiec61883-1.1.0.ebuild,v 1.4 2006/11/09 09:29:22 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libiec61883/libiec61883-1.1.0.ebuild,v 1.5 2007/01/04 15:22:18 flameeyes Exp $
 
 WANT_AUTOMAKE="latest"
 WANT_AUTOCONF="latest"
@@ -24,15 +24,15 @@ DEPEND="${RDEPEND}
 src_unpack() {
        unpack ${A}
        cd ${S}
-       libtoolize --copy --force
 
        if use examples
        then
                sed -i -e "s:noinst_PROGRAMS.*:noinst_PROGRAMS = :g" \
                -e "s:in_PROGRAMS.*:in_PROGRAMS = plugreport plugctl test-amdtp test-dv test-mpeg2 test-plugs:g" \
                examples/Makefile.am || die "noinst patching failed"
-               eautoreconf
        fi
+
+       eautoreconf
 }
 
 src_install () {
index ec3227cb7b254cd0a02872ec417db4321fa1149e..15b3112b1597afee990461409d6063e158e1ab54 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for media-libs/tunepimp
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/tunepimp/ChangeLog,v 1.47 2006/12/26 14:47:17 gustavoz Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tunepimp/ChangeLog,v 1.48 2007/01/04 15:20:56 flameeyes Exp $
+
+  04 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> tunepimp-0.5.2.ebuild:
+  Fix broken autotools handling.
 
   26 Dec 2006; Gustavo Zacarias <gustavoz@gentoo.org> tunepimp-0.5.2.ebuild:
   Stable on sparc wrt #158836
index 79c824be6d2b91d9b207f4ee7dd18834c0eabaca..de00fe10e2b6af7d54c09af9dd0257579643f5ec 100644 (file)
@@ -1,8 +1,11 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/tunepimp/tunepimp-0.5.2.ebuild,v 1.8 2006/12/26 14:47:17 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tunepimp/tunepimp-0.5.2.ebuild,v 1.9 2007/01/04 15:20:56 flameeyes Exp $
 
-inherit eutils distutils perl-app
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit eutils distutils autotools
 
 MY_P="lib${P}"
 S="${WORKDIR}/${MY_P}"
@@ -31,22 +34,13 @@ RDEPEND="sys-libs/zlib
 DEPEND="${RDEPEND}
        dev-util/pkgconfig"
 
-src_compile() {
-       # broken script, install fails
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+
        sed -i -e "s: tta::" configure.in
-       libtoolize --copy --force
-       autoheader
-       automake --foreign --add-missing --copy --include-deps
-       aclocal
-       autoconf
 
-       econf || die "configure failed"
-       emake || die "emake failed"
-       # disabled as broken with Perl 5.8.8
-       #if use perl; then
-       #       cd ${S}/perl/tunepimp-perl
-       #       perl-app_src_compile || die "perl module failed to compile"
-       #fi
+       eautoreconf
 }
 
 src_install() {
@@ -59,10 +53,4 @@ src_install() {
                insinto /usr/share/doc/${PF}/examples/
                doins examples/*
        fi
-#      if use perl; then
-#              cd ${S}/perl/tunepimp-perl
-#              perl-module_src_install || die "perl module failed to install"
-#              insinto /usr/share/doc/${PF}/examples/
-#              doins examples/*
-#      fi
 }