app-misc/ondir: EAPI 6 bump.
authorPatrice Clement <monsieurp@gentoo.org>
Tue, 26 Dec 2017 18:57:53 +0000 (19:57 +0100)
committerPatrice Clement <monsieurp@gentoo.org>
Tue, 26 Dec 2017 18:58:13 +0000 (19:58 +0100)
Bug: https://bugs.gentoo.org/642166
Package-Manager: Portage-2.3.13, Repoman-2.3.3

app-misc/ondir/ondir-0.2.2-r2.ebuild [new file with mode: 0644]

diff --git a/app-misc/ondir/ondir-0.2.2-r2.ebuild b/app-misc/ondir/ondir-0.2.2-r2.ebuild
new file mode 100644 (file)
index 0000000..d483901
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Automatically execute scripts as you traverse directories"
+HOMEPAGE="http://swapoff.org/OnDir"
+SRC_URI="http://swapoff.org/files/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+DEPEND="sys-apps/sed"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog README INSTALL scripts.tcsh scripts.sh )
+HTML_DOCS=(  changelog.html ondir.1.html )
+
+src_prepare() {
+       default
+       sed -i \
+               -e "s:\(/man/.*$\):/share\1:g" \
+               -e "s:-g:${CFLAGS}:" Makefile || die "sed Makefile failed"
+}
+
+src_compile() {
+       emake \
+               CC="$(tc-getCC)" \
+               PREFIX="${EPREFIX}/usr" \
+               CONF="${EPREFIX}/etc/ondirrc" \
+               LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+       default
+       emake \
+               DESTDIR="${D}" \
+               PREFIX="${EPREFIX}/usr" \
+               CONF="${EPREFIX}/etc/ondirrc" \
+               install
+       newdoc ondirrc.eg ondirrc.example
+}