net-analyzer/nmap: apply workaround not to destroy a fix for Darwin, bug #604432
authorFabian Groffen <grobian@gentoo.org>
Tue, 3 Jan 2017 14:08:42 +0000 (15:08 +0100)
committerFabian Groffen <grobian@gentoo.org>
Tue, 3 Jan 2017 14:08:59 +0000 (15:08 +0100)
Package-Manager: portage-2.2.28-prefix

net-analyzer/nmap/nmap-7.40.ebuild
net-analyzer/nmap/nmap-9999.ebuild

index 1fe61b52a27691a048a3c482f9b678fcdf420519..28b7751640f05e8d3821c9484b27b150b7c75b6c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -111,7 +111,12 @@ src_prepare() {
 
        epatch_user
 
+       cp libdnet-stripped/include/config.h.in{,.nmap-orig} || die
        eautoreconf
+       if [[ ${CHOST} == *-darwin* ]] ; then
+               # we need the original for a Darwin-specific fix, bug #604432
+               mv libdnet-stripped/include/config.h.in{.nmap-orig,} || die
+       fi
 }
 
 src_configure() {
index 7ed59bdaa4ecc4f77132f5de2ad7a27b88cfdc94..b7315c6804105e3027b54bd160d2be8a2fd62080 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -99,7 +99,12 @@ src_prepare() {
 
        epatch_user
 
+       cp libdnet-stripped/include/config.h.in{,.nmap-orig} || die
        eautoreconf
+       if [[ ${CHOST} == *-darwin* ]] ; then
+               # we need the original for a Darwin-specific fix, bug #604432
+               mv libdnet-stripped/include/config.h.in{.nmap-orig,} || die
+       fi
 }
 
 src_configure() {