dev-python/hypothesis: Bump to 5.1.4
authorMichał Górny <mgorny@gentoo.org>
Sun, 12 Jan 2020 06:37:51 +0000 (07:37 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 12 Jan 2020 09:17:36 +0000 (10:17 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/hypothesis/Manifest
dev-python/hypothesis/hypothesis-5.1.4.ebuild [new file with mode: 0644]

index 76c5001c67badeaed74e6483adbd555a44ec628d..45c3da40853eaa14e6db6e645a2b4b39b9a81386 100644 (file)
@@ -5,3 +5,4 @@ DIST hypothesis-python-4.55.4.tar.gz 9004357 BLAKE2B 93fe51581f044cf5f416d9b74b8
 DIST hypothesis-python-4.57.1.tar.gz 9005030 BLAKE2B 3d318896cbe2d24fa6847e764a109791d3acf3821852f8e170991b0be5b069f166e16bdacf7a82fbe49bd9db5188315cdec7cdb4592647571233949ec5732991 SHA512 28622ce8a1d89d09df65f3fbf7e92a1ad98dac140ab646fe11fcb15e6aa9a9672eb51d459f984384d92b819f902de911b06cec2542582d529dd556d2f99ed952
 DIST hypothesis-python-5.1.2.tar.gz 8989829 BLAKE2B 7063b859c8c180412b2d9b2641faefc861e52444b45d4bc455ba8309f44ee24c27e6c9a6d18e93fb0455a93d09d8b30a0d313313212436227f989ad7dd0d1b87 SHA512 48150a3ea6d1c6270cf016a363f110f29e6e2adc2bfa98947581dc963a0a19398609c21251f821c9e741e743411a989730000bff83d9c5a1b95b805408e32df1
 DIST hypothesis-python-5.1.3.tar.gz 8989332 BLAKE2B a86409b0620b3821aae8f23f0473be08ed1152140f05c2ebcb3f226cc133fdbbb617856c768bc6034bcf25e6603e9e72b1b885df116fb9dfce7164018792fb99 SHA512 dd854158c1e903562c7aa101fe7810837816102b1f5dd840ec3d5df9abd9c1463d05adab79ef428749ea2a5d1a425150971d23ae3259b71baf0e0e8a8a9a3bb8
+DIST hypothesis-python-5.1.4.tar.gz 8989696 BLAKE2B 9d85cb1473654e36a235a07d2390fc967d6d7f2944e5294dedbca15ddb3c49901b04e9277ee80ff7591aa2b81ea0e2d537051f96b685900aefab5db70d135ac6 SHA512 25d0112f7b7a13221b8b68d553f4085344f1e8681c8795fac0bcfd714400a828539298d2919d3e638979eadd5daa65ef7ee8b0b946df076145e59c8bb7058a64
diff --git a/dev-python/hypothesis/hypothesis-5.1.4.ebuild b/dev-python/hypothesis/hypothesis-5.1.4.ebuild
new file mode 100644 (file)
index 0000000..24078c5
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+       >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               ${RDEPEND}
+               dev-python/mock[${PYTHON_USEDEP}]
+               dev-python/pexpect[${PYTHON_USEDEP}]
+               >=dev-python/pytest-4.3[${PYTHON_USEDEP}]
+               !!<dev-python/typing-3.7.4.1
+       )
+"
+
+src_prepare() {
+       # avoid pytest-xdist dep for one test
+       sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
+               tests/pytest/test_statistics.py || die
+       distutils-r1_src_prepare
+}
+
+python_test() {
+       pytest -vv tests/cover tests/pytest tests/quality ||
+               die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+       optfeature "datetime support" dev-python/pytz
+       optfeature "dateutil support" dev-python/python-dateutil
+       optfeature "numpy support" dev-python/numpy
+       optfeature "django support" dev-python/django dev-python/pytz
+       optfeature "pandas support" dev-python/pandas
+       optfeature "pytest support" dev-python/pytest
+}