dev-python/construct: update to 2.9.46
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>
Wed, 13 Nov 2019 20:46:24 +0000 (23:46 +0300)
committerMichał Górny <mgorny@gentoo.org>
Tue, 21 Apr 2020 11:24:23 +0000 (13:24 +0200)
Drop python2_7, add python3_7, enable tests

Closes: https://bugs.gentoo.org/679424
Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com>
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/construct/Manifest
dev-python/construct/construct-2.9.46.ebuild [new file with mode: 0644]

index 4f626d0013db3da57a6f2379ffe4e174008829db..2922215411f77eab050b3cc1bda39f3a9e3d6d35 100644 (file)
@@ -1 +1,2 @@
 DIST construct-2.9.45.tar.gz 1042299 BLAKE2B 4d646c3a340b969e83e15436422732f4f4380ef24cd0e9f258f3d3666f17b08ab628d19db39bb8fcd3f370c2b0c93a8329fba56727f28d7a23d868d001610927 SHA512 78d64f3e567e6c9cef842d3e15f416d48856d229a8c6f21e282d3123a86fdd243b20dba5040c6e1d28b67422881351b303262132263efdf94bb73adde0d5dfc1
+DIST construct-2.9.46.tar.gz 1042624 BLAKE2B df42f771fbba3867b2bf5eb60fadd8f314207b101e3ce695ed58fa9db8c13c3b746c9b6a8979dfbfa0f5b8182aab4b7fdc7e678e017acc3223252a82d5e62640 SHA512 01bd135b2e08958749eab1e79abb912d7da94743567b8165f6dc1b0edbbb765f1e7ba7e120fda1fef8bcd24a285d164b017f49527382921018091cc654d28cae
diff --git a/dev-python/construct/construct-2.9.46.ebuild b/dev-python/construct/construct-2.9.46.ebuild
new file mode 100644 (file)
index 0000000..ebb156a
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A powerful declarative parser for binary data"
+HOMEPAGE="https://construct.readthedocs.io/en/latest/ https://pypi.org/project/construct/"
+SRC_URI="https://github.com/construct/construct/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+BDEPEND+="
+       test? (
+               dev-python/arrow[${PYTHON_USEDEP}]
+               >=dev-python/numpy-1.15.4[${PYTHON_USEDEP}]
+       )"
+
+src_prepare() {
+       default
+       rm tests/test_benchmarks.py || die
+}
+
+pkg_postinst() {
+       ewarn "Version 2.9.x has significant API and implementation changes from"
+       ewarn "previous 2.8.x releases. Please read the documentation at"
+       ewarn "https://construct.readthedocs.io/en/latest/transition29.html"
+       ewarn "for more info."
+}