dev-util/glslang: Fix relative includes in headers
authorNick Sarnie <sarnex@gentoo.org>
Tue, 29 Oct 2019 02:18:28 +0000 (22:18 -0400)
committerNick Sarnie <sarnex@gentoo.org>
Tue, 29 Oct 2019 02:18:28 +0000 (22:18 -0400)
Needed to fix media-libs/shaderc build. Patch developed and tested by chutzpah

Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
dev-util/glslang/files/glslang-7.12.3353_pre20191027-fix-relative-includes.patch [new file with mode: 0644]
dev-util/glslang/glslang-7.12.3353_pre20191027-r1.ebuild [new file with mode: 0644]
dev-util/glslang/glslang-9999.ebuild

diff --git a/dev-util/glslang/files/glslang-7.12.3353_pre20191027-fix-relative-includes.patch b/dev-util/glslang/files/glslang-7.12.3353_pre20191027-fix-relative-includes.patch
new file mode 100644 (file)
index 0000000..4c44cfb
--- /dev/null
@@ -0,0 +1,26 @@
+diff --git a/SPIRV/GlslangToSpv.h b/SPIRV/GlslangToSpv.h
+index 86e1c23b..3907be43 100755
+--- a/SPIRV/GlslangToSpv.h
++++ b/SPIRV/GlslangToSpv.h
+@@ -40,7 +40,7 @@
+ #endif
+ #include "SpvTools.h"
+-#include "../glslang/Include/intermediate.h"
++#include "glslang/Include/intermediate.h"
+ #include <string>
+ #include <vector>
+diff --git a/SPIRV/SpvTools.h b/SPIRV/SpvTools.h
+index 7422d012..59c914da 100644
+--- a/SPIRV/SpvTools.h
++++ b/SPIRV/SpvTools.h
+@@ -46,7 +46,7 @@
+ #include <ostream>
+ #endif
+-#include "../glslang/MachineIndependent/localintermediate.h"
++#include "glslang/MachineIndependent/localintermediate.h"
+ #include "Logger.h"
+ namespace glslang {
diff --git a/dev-util/glslang/glslang-7.12.3353_pre20191027-r1.ebuild b/dev-util/glslang/glslang-7.12.3353_pre20191027-r1.ebuild
new file mode 100644 (file)
index 0000000..7c674c7
--- /dev/null
@@ -0,0 +1,19 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-multilib cmake-utils
+
+SNAPSHOT_COMMIT="b131630e7c749a5dc19faa458024260c71fb170f"
+SRC_URI="https://github.com/KhronosGroup/${PN}/archive/${SNAPSHOT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+S="${WORKDIR}/glslang-${SNAPSHOT_COMMIT}"
+
+DESCRIPTION="Khronos reference front-end for GLSL and ESSL, and sample SPIR-V generator"
+HOMEPAGE="https://www.khronos.org/opengles/sdk/tools/Reference-Compiler/"
+
+LICENSE="BSD"
+SLOT="0"
+
+PATCHES=( "${FILESDIR}/${P}-fix-relative-includes.patch" )
index 63a6238d03f8749c12583059ef823c1aaa276378..4283dcd2371b85c3fe877a44a0a5312b8f714b52 100644 (file)
@@ -13,3 +13,5 @@ HOMEPAGE="https://www.khronos.org/opengles/sdk/tools/Reference-Compiler/"
 
 LICENSE="BSD"
 SLOT="0"
+
+PATCHES=( "${FILESDIR}/${P}-fix-relative-includes.patch" )