dev-python/pycadf: Clean old up
authorMichał Górny <mgorny@gentoo.org>
Fri, 5 Jan 2018 22:04:30 +0000 (23:04 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 5 Jan 2018 23:19:03 +0000 (00:19 +0100)
dev-python/pycadf/Manifest
dev-python/pycadf/pycadf-2.5.0.ebuild [deleted file]

index ed880ab953047a29dca2a0291ef23e14020fe480..841609b6912189b133addd006cdd5ff4e32a0232 100644 (file)
@@ -1,2 +1 @@
-DIST pycadf-2.5.0.tar.gz 247779 BLAKE2B 44460c259aa9eebff8d8e8ea3d04aa874019b08ac116b8662dbcd4ec2f4089344e510c70bea24d7ffb9c53ee995883e5db558af7afed3d55646c625e0cd78453 SHA512 af3d7676e671ed702a84052589be7146406c2c53ebfb1ee5922bec93664fac461514c832ce9f225d52a9c6b08ec330e17c5763bee6eda7a931b5dc0af6e57ed5
 DIST pycadf-2.6.0.tar.gz 249411 BLAKE2B 7ddbbcb9355502910ba023589181cbf2d6a104454ca408b604eee031ce79c547213961d10bec4d891e8ddfb00ccacaf1dff1f5bb2646913e9c0bb79abfd4ae72 SHA512 a581b54a8dae088e015d639f14eb46b3c41bdbfdd55b671e79f34b7392af49e3e8dbb2fd85a43e5f8e010cbcdba1d9a330972b5cb6f7f2c5179c00b6f135b4ec
diff --git a/dev-python/pycadf/pycadf-2.5.0.ebuild b/dev-python/pycadf/pycadf-2.5.0.ebuild
deleted file mode 100644 (file)
index 75af4f8..0000000
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
-
-inherit distutils-r1
-
-DESCRIPTION="python implementation of DMTF Cloud Audit (CADF) data model"
-HOMEPAGE="https://pypi.python.org/pypi/pycadf"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="doc test"
-
-CDEPEND=">=dev-python/pbr-1.8.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       ${CDEPEND}
-       test? (
-               >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
-               >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
-               >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
-               >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
-               >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
-               >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
-               >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]
-               >=dev-python/sphinx-1.2.1[${PYTHON_USEDEP}]
-               <dev-python/sphinx-1.4[${PYTHON_USEDEP}]
-       )
-       doc? (
-               >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]
-               >=dev-python/sphinx-1.2.1[${PYTHON_USEDEP}]
-               <dev-python/sphinx-1.4[${PYTHON_USEDEP}]
-       )"
-RDEPEND="
-       ${CDEPEND}
-       >=dev-python/oslo-config-3.14.0[${PYTHON_USEDEP}]
-       !~dev-python/oslo-config-3.18.0[${PYTHON_USEDEP}]
-       >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
-       >=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
-       >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
-       >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
-       sed -i '/^hacking/d' test-requirements.txt || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       use doc && "${PYTHON}" setup.py build_sphinx
-}
-
-python_test() {
-       testr init || die "testr init failed under ${EPYTHON}"
-       testr run || die "testr run failed under ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/build/html/. )
-       distutils-r1_python_install_all
-}