sys-apps/hw-probe: new package
authorConrad Kostecki <conikost@gentoo.org>
Sun, 10 May 2020 19:24:10 +0000 (21:24 +0200)
committerConrad Kostecki <conikost@gentoo.org>
Sun, 10 May 2020 19:24:48 +0000 (21:24 +0200)
Hardware Probe Tool is a tool to probe for hardware,
check it's operability and find drivers.
The probes are uploaded to the Linux hardware database.
See https://linux-hardware.org for more information.

Closes: https://bugs.gentoo.org/669722
Closes: https://github.com/gentoo/gentoo/pull/10246
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
sys-apps/hw-probe/Manifest [new file with mode: 0644]
sys-apps/hw-probe/files/README.gentoo [new file with mode: 0644]
sys-apps/hw-probe/hw-probe-1.5.ebuild [new file with mode: 0644]
sys-apps/hw-probe/metadata.xml [new file with mode: 0644]

diff --git a/sys-apps/hw-probe/Manifest b/sys-apps/hw-probe/Manifest
new file mode 100644 (file)
index 0000000..dcd90fe
--- /dev/null
@@ -0,0 +1 @@
+DIST hw-probe-1.5.tar.gz 113996 BLAKE2B 59f6fc27e2cbb99a4b7dd9428e32a93dce2ffcc1133e82539b8836a694e6c5634fe2e172732675acf0d83504907a750c63f138d6dec236039eb7c805010a8383 SHA512 80dd2484bd317ac1e86d7f434626f288648aebf110a4bf81c0c05548abcb19d990119c1690fcb5796384a6c32fd5c1e827698a31165bfc41ef6df9fc7fdd368d
diff --git a/sys-apps/hw-probe/files/README.gentoo b/sys-apps/hw-probe/files/README.gentoo
new file mode 100644 (file)
index 0000000..521f7f4
--- /dev/null
@@ -0,0 +1,7 @@
+Please keep in mind, that all results are being uploaded
+by default directly to the Linux Hardware Database
+and can be read by everyone in public.
+
+In order to identify unique computers and hard drives,
+a 32-byte prefix of a salted SHA512 hash from
+MAC addresses and serial numbers is being uploaded.
diff --git a/sys-apps/hw-probe/hw-probe-1.5.ebuild b/sys-apps/hw-probe/hw-probe-1.5.ebuild
new file mode 100644 (file)
index 0000000..cd01ab7
--- /dev/null
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils readme.gentoo-r1
+
+DESCRIPTION="A tool to probe for hardware, check it's operability and find drivers"
+HOMEPAGE="https://github.com/linuxhw/hw-probe/"
+SRC_URI="https://github.com/linuxhw/hw-probe/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       dev-lang/perl
+       dev-perl/Digest-SHA1
+       net-misc/curl
+       sys-apps/dmidecode
+       sys-apps/edid-decode
+       sys-apps/hwinfo
+       sys-apps/pciutils
+       sys-apps/smartmontools
+       sys-apps/usbutils
+       virtual/perl-Data-Dumper
+"
+
+src_compile() {
+       :;
+}
+
+src_install() {
+       default
+
+       readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+       readme.gentoo_print_elog
+
+       optfeature "showing Machine Check Exceptions." app-admin/mcelog
+       optfeature "showing additional I/O statistics." app-admin/sysstat
+       optfeature "showing smart card (reader) information." dev-libs/opensc
+       optfeature "showing Vulkan GPU hardware information." dev-util/vulkan-tools
+       optfeature "showing information of attached scanners." media-gfx/sane-backends
+       optfeature "showing GPU information provided by MESA." media-libs/mesa
+       optfeature "showing zeroconf statistics." net-dns/avahi
+       optfeature "showing HP printer statistics." net-print/hplip
+       optfeature "showing status about rfkill switches on communication devices." net-wireless/rfkill
+       optfeature "showing additional CPU capabilities." sys-apps/cpuid
+       optfeature "showing hard disk (HDD, SSD, ..) capabilities." sys-apps/hdparm
+       optfeature "showing available I2C sensors." sys-apps/i2c-tools
+       optfeature "showing additional hardware and system information detected by inxi." sys-apps/inxi
+       optfeature "showing information about tested memory for faults." sys-apps/memtester
+       optfeature "showing 'Plug & Play' devices." sys-apps/pnputils
+       optfeature "showing systemd boot process information." sys-apps/systemd
+       optfeature "showing ACPI statistics and tables." sys-power/iasl
+       optfeature "showing information about NUMA." sys-process/numactl
+       optfeature "showing additional GPU information provided by MESA progs." x11-apps/mesa-progs
+       optfeature "showing available Xinput devices." x11-apps/xinput
+}
diff --git a/sys-apps/hw-probe/metadata.xml b/sys-apps/hw-probe/metadata.xml
new file mode 100644 (file)
index 0000000..55a7ebd
--- /dev/null
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>conikost@gentoo.org</email>
+               <name>Conrad Kostecki</name>
+       </maintainer>
+       <longdescription>
+               Hardware Probe Tool is a tool to probe for hardware,
+               check it's operability and find drivers.
+               The probes are uploaded to the Linux hardware database.
+               See https://linux-hardware.org for more information.
+       </longdescription>
+       <upstream>
+               <bugs-to>https://github.com/linuxhw/hw-probe/issues</bugs-to>
+               <remote-id type="github">linuxhw/hw-probe</remote-id>
+       </upstream>     
+</pkgmetadata>