app-emulation/runc: Add new snapshot
authorManuel Rüger <mrueg@gentoo.org>
Thu, 23 Feb 2017 14:57:50 +0000 (15:57 +0100)
committerManuel Rüger <mrueg@gentoo.org>
Thu, 23 Feb 2017 14:59:02 +0000 (15:59 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

app-emulation/runc/Manifest
app-emulation/runc/runc-1.0.0_rc2_p20170222.ebuild [new file with mode: 0644]

index 9c9a5c09373c932a067ac8641130b15978825a47..7f076980753016075f8e5407877f67ef8600b3e4 100644 (file)
@@ -1 +1,2 @@
 DIST runc-1.0.0_rc2.tar.gz 550449 SHA256 638742c48426b9a3281aeb619e27513d972de228bdbd43b478baea99c186d491 SHA512 83a3d45efbb86d3d583b96062202b9e60121d250af2c0dd37d07fda574b642aa6f05e29cac6644ad3d624647400db694082e280383e41ca9f31dc0a33b87ed76 WHIRLPOOL 990a45739689db80bbeed43b0fd3a4ce4d0563ea833361b9112e750782313f19e638c4bfbd455f5dd1882d64c724dcf0213701322029c2c9f98f624863c744f3
+DIST runc-1.0.0_rc2_p20170222.tar.gz 576999 SHA256 1ee6491b9c14e0ce9e0546ed92e3eb4bdc60cf4b5e58b6de0455dbe3b03145cb SHA512 fe293057f55eee4f3821004af730ad57f512d610d7cf3693b26e69ffa068c8c28da5426b9f4988627c0803ecd1d46b6e427db8f1703649f5861859d61cd24bbd WHIRLPOOL 561c09ffc7d3e0f1dd73f3711adb85b74d5fea265181cdd1535a83d23a164c1e4cb884053c0b46c968b0b582feeb2ccc9eb99e3e086b1fcbcce0813f4444172c
diff --git a/app-emulation/runc/runc-1.0.0_rc2_p20170222.ebuild b/app-emulation/runc/runc-1.0.0_rc2_p20170222.ebuild
new file mode 100644 (file)
index 0000000..b68956a
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+EGO_PN="github.com/opencontainers/${PN}"
+
+if [[ ${PV} == *9999 ]]; then
+       inherit golang-vcs
+else
+       MY_PV="${PV/_/-}"
+       EGIT_COMMIT="bd2f9c52cd3b766d993924ae6eba72b82998f3bd"
+       RUNC_COMMIT="bd2f9c" # Change this when you update the ebuild
+       SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~ppc64"
+       inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="runc container cli tools"
+HOMEPAGE="http://runc.io"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="apparmor hardened +seccomp"
+
+RDEPEND="
+       apparmor? ( sys-libs/libapparmor )
+       seccomp? ( sys-libs/libseccomp )
+"
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+src_compile() {
+       # Taken from app-emulation/docker-1.7.0-r1
+       export CGO_CFLAGS="-I${ROOT}/usr/include"
+       export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')
+               -L${ROOT}/usr/$(get_libdir)"
+
+       # Setup GOPATH so things build
+       rm -rf .gopath
+       mkdir -p .gopath/src/"$(dirname "${GITHUB_URI}")"
+       ln -sf ../../../.. .gopath/src/"${GITHUB_URI}"
+       export GOPATH="${PWD}/.gopath:${PWD}/vendor"
+
+       # build up optional flags
+       local options=(
+               $(usex apparmor 'apparmor')
+               $(usex seccomp 'seccomp')
+       )
+
+       emake BUILDTAGS="${options[*]}" \
+               COMMIT="${RUNC_COMMIT}"
+}
+
+src_install() {
+       dobin runc
+}