app-misc/recoll: 1.24.1 version bump, fix build with Qt 5.11
authorPunarbasu Purkayastha <ppurka@gmail.com>
Fri, 17 Aug 2018 20:59:07 +0000 (22:59 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 17 Aug 2018 22:02:02 +0000 (00:02 +0200)
Fixes build with Qt 5.11.

Closes: https://bugs.gentoo.org/663028
Closes: https://bugs.gentoo.org/660912
Package-Manager: Portage-2.3.46, Repoman-2.3.10

app-misc/recoll/Manifest
app-misc/recoll/files/recoll-1.24.1-qt-5.11.patch [new file with mode: 0644]
app-misc/recoll/recoll-1.24.1.ebuild [new file with mode: 0644]

index fcbacd126c10bf5440290292191b1807efc3ee3e..ff2c982bc7b2d8c84209ba7cfbd387ad08f1da1f 100644 (file)
@@ -1,2 +1,3 @@
 DIST recoll-1.23.3.tar.gz 2590148 BLAKE2B ec058bac500aa61b4e395720bffcc2bfbcaded954c986e8e1fe69720456267c33b5e34eb3e28de47f57d9af207c60b138c521792882b093120b988b682600b2a SHA512 bfad118dd9561c8d18e194b11d8014e2f9ea74f6aaf50f91704087775e6f72d5f3574a3eafe470dab7658cb4a7233817a672af939f21b3e69c719e599bc5cd06
 DIST recoll-1.23.6.tar.gz 2601494 BLAKE2B e64ed422a1ac1a816091f9ee00ee23b551690f5038cf3378a00ebf39c9e4f4e22436105ed01a1aa2bc21b633c85a73ba2847a265e4d199109a8b0c03ec53421e SHA512 ae6f6dfe5e63faf2310b32bd0ffd90f08b12de7452ded9e5bd58a45690797caa9f5c66ea94ef94ed7a4ee3e55083cc191fbecfc112dbce42415d0af1300fe8fd
+DIST recoll-1.24.1.tar.gz 2644672 BLAKE2B e5bce2231e075fe9a2bfad7d0d1068906e625106b09247dc5baffaf92957db111dd6be90c658266b8b9940d885b3495769c68ce66247d00568df24c1b5222226 SHA512 60bf57d2718a21dbd578fa1dc73a542fc7ab2152c4c5bb763885b19c14d080340587cb8c01f82f1ca7d1cb63a03edf03b4501f3ef63f06ab6506356c4a0a095c
diff --git a/app-misc/recoll/files/recoll-1.24.1-qt-5.11.patch b/app-misc/recoll/files/recoll-1.24.1-qt-5.11.patch
new file mode 100644 (file)
index 0000000..146bc98
--- /dev/null
@@ -0,0 +1,12 @@
+diff --git a/qtgui/ssearch_w.cpp b/qtgui/ssearch_w.cpp
+index 2d0c97c..ca72af1 100644
+--- a/qtgui/ssearch_w.cpp
++++ b/qtgui/ssearch_w.cpp
+@@ -32,6 +32,7 @@
+ #include <qevent.h>
+ #include <QTimer>
+ #include <QCompleter>
++#include <QAbstractItemView>
+ #include "log.h"
+ #include "guiutils.h"
\ No newline at end of file
diff --git a/app-misc/recoll/recoll-1.24.1.ebuild b/app-misc/recoll/recoll-1.24.1.ebuild
new file mode 100644 (file)
index 0000000..a3d7abc
--- /dev/null
@@ -0,0 +1,125 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils linux-info python-single-r1 qmake-utils
+
+DESCRIPTION="A personal full text search package"
+HOMEPAGE="http://www.lesbonscomptes.com/recoll/"
+SRC_URI="http://www.lesbonscomptes.com/recoll/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="camelcase doc +inotify qt5 session +spell"
+REQUIRED_USE="session? ( inotify ) ${PYTHON_REQUIRED_USE}"
+
+CDEPEND="
+       dev-libs/xapian:=
+       sys-libs/zlib:=
+       virtual/libiconv
+       qt5? (
+               dev-qt/qtcore:5
+               dev-qt/qtgui:5
+               dev-qt/qtprintsupport:5
+               dev-qt/qtwebkit:5
+       )
+       session? (
+               inotify? (
+                         x11-libs/libSM
+                         x11-libs/libICE
+                         x11-libs/libX11
+               )
+       )
+       spell? ( app-text/aspell )
+       ${PYTHON_DEPS}
+"
+
+DEPEND="
+       ${CDEPEND}
+       qt5? ( dev-qt/linguist-tools:5 )
+"
+
+RDEPEND="
+       ${CDEPEND}
+       app-arch/unzip
+"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-python3.patch # python3 patch
+       "${FILESDIR}"/${P}-qt-5.11.patch # bugs 663028, 660912
+)
+
+pkg_setup() {
+       if has_version "<app-misc/recoll-1.20"; then
+               einfo "Installing ${PV} over an 1.19 index is possible,"
+               einfo "but there have been small changes in the way"
+               einfo "compound words are indexed. So it is best to reset"
+               einfo "the index. The best method to reset the index is to"
+               einfo "quit all recoll programs and delete the index directory"
+               einfo "rm -rf ~/.recoll/xapiandb, then start recoll or recollindex."
+       fi
+       if use inotify; then
+               CONFIG_CHECK="~INOTIFY_USER"
+               check_extra_config
+       fi
+       python-single-r1_pkg_setup
+}
+
+src_prepare() {
+       default
+       python_fix_shebang filters
+}
+
+src_configure() {
+       use qt5 && export QMAKE="$(qt5_get_bindir)/qmake"
+
+       econf \
+               $(use_enable camelcase) \
+               $(use_enable session x11mon) \
+               $(use_enable qt5 qtgui) \
+               $(use_enable qt5 webkit) \
+               $(use_with inotify) \
+               $(use_with spell aspell) \
+               --without-fam \
+               --enable-recollq
+}
+
+src_install() {
+       emake STRIP="$(type -P true)" DESTDIR="${D}" install
+
+       # html docs should be placed in /usr/share/doc/${PN}/html
+       use doc && dodoc -r "${ED}"/usr/share/recoll/doc/.
+       rm -r "${ED}/usr/share/recoll/doc" || die
+       find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+       einfo "In order to extract the full functionality of "
+       einfo "recoll, the following packages should be installed "
+       einfo "to get the corresponding document support."
+
+       optfeature "XML based documents support"    "dev-libs/libxslt[python] dev-libs/libxml2[python]"
+       optfeature "PDF files support"              app-text/poppler
+       optfeature "PDF files with OCR support"     app-text/tesseract
+       optfeature "MS Word files support"          app-text/antiword
+       optfeature "Wordperfect files support"      "app-text/libwpd[tools]"
+       optfeature "Lyx files support"              app-office/lyx
+       optfeature "CHM files support"              dev-python/pychm
+       optfeature "GNU Info files support"         sys-apps/texinfo
+       optfeature "RAR archives support"           dev-python/rarfile
+       optfeature "7zip archives support"          dev-python/pylzma
+       optfeature "iCalendar files support"        dev-python/icalendar
+       optfeature "Postscript files support"       app-text/pstotext
+       optfeature "RTF files support"              app-text/unrtf
+       optfeature "TeX files support"              dev-text/detex
+       optfeature "DVI files support"              virtual/tex-base
+       optfeature "DJVU files support"             app-text/djvu
+       optfeature "tags in audio files support"    media-libs/mutagen
+       optfeature "tags in image files support"    media-libs/exiftool
+       optfeature "Midi karaoke files support"     dev-python/chardet
+}