projects
/
gentoo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
d2b209c
)
dev-python/slimit: Set DISTUTILS_USE_SETUPTOOLS
author
Michał Górny
<mgorny@gentoo.org>
Wed, 25 Mar 2020 08:49:59 +0000
(09:49 +0100)
committer
Michał Górny
<mgorny@gentoo.org>
Wed, 25 Mar 2020 09:39:41 +0000
(10:39 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/slimit/slimit-0.8.1-r1.ebuild
patch
|
blob
|
history
diff --git
a/dev-python/slimit/slimit-0.8.1-r1.ebuild
b/dev-python/slimit/slimit-0.8.1-r1.ebuild
index c65e63cdd4269b002eda0f99ba82b005737b0821..ca7d58331ceb94a0c5bdaef81636b8856b7ea27b 100644
(file)
--- a/
dev-python/slimit/slimit-0.8.1-r1.ebuild
+++ b/
dev-python/slimit/slimit-0.8.1-r1.ebuild
@@
-3,7
+3,9
@@
EAPI=6
+DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( pypy3 python3_6 )
+
inherit distutils-r1
DESCRIPTION="A JavaScript minifier written in Python"
@@
-16,8
+18,7
@@
KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
-RDEPEND="dev-python/ply:=[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/ply:=[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
test? (
dev-python/pytest[${PYTHON_USEDEP}]