dev-python/pyrsistent: Bump to version 0.12.0
authorLars Wendler <polynomial-c@gentoo.org>
Mon, 23 Jan 2017 02:48:32 +0000 (03:48 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Mon, 23 Jan 2017 03:37:54 +0000 (04:37 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-python/pyrsistent/Manifest
dev-python/pyrsistent/pyrsistent-0.12.0.ebuild [new file with mode: 0644]

index cbda766b0c545e4349abbd7134fa1201f85159c6..6985508a441e372918dedbf0dd208628ed2cdff8 100644 (file)
@@ -1,2 +1,3 @@
 DIST pyrsistent-0.11.12.tar.gz 88621 SHA256 255e6e3e1373b93e65158ae0a672a5ba6d01b18f92d8eab319969b81e784fe49 SHA512 66424adb4d1e69d500cfbb2f9dd0d3d5f9678cd7ee7ca02909a714b7351412022cdb9507417318df3027287f0ffed9f2872dd8fb489e236f1769527a81756d1c WHIRLPOOL 04a52d660c901156de93fed94dee337b2f218cce7ab4f7b8434176565216e543c7ff839c421e219ffaa9b20d1914d51a7514463e0f706baae3ad7b89eb9c17ba
 DIST pyrsistent-0.11.13.tar.gz 89444 SHA256 cfbf194cb33b97722f6a3d6efa7b6e7a93b09bb13571266cfc9c1556fdb26f29 SHA512 0911fd49598ea35a8a95cbda7ee28175b4708be1b3fe23340e731c7735e2436f6ec9ad390482e02dc51e337c6b9803920471ab76540b003e99a20b00649fbfe1 WHIRLPOOL 50a57cb2e2f2cd9d88587a229a890b0da46151bdb393b1acf5f42f3d6cfc58b561b5998ab9b7bcfd2c21c68d54c2929f2c017b3c1073d5f1a92c6f4865d51b59
+DIST pyrsistent-0.12.0.tar.gz 91666 SHA256 37e19cb03435a81507f3096bec2abfbe6a1bb4098f72159d0cd37f6f8394f3cc SHA512 dd0041011cb5aa41d32cfd632e80079a1e0e19f15366c928eabc040a85e9b574dc2d1a87139b150fa8ec42f6955ddffbf6e7bf8bfd9f498a9089632189949853 WHIRLPOOL b131eaf46a35ec5dd1cdc4818d271f784093faba1d50b67713429c84946811c72cd7d73bec1c5d3a44ac992ca4abbe347bd59155ae94d9703b749cd9f0ec8dd4
diff --git a/dev-python/pyrsistent/pyrsistent-0.12.0.ebuild b/dev-python/pyrsistent/pyrsistent-0.12.0.ebuild
new file mode 100644 (file)
index 0000000..516a874
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Persistent/Functional/Immutable data structures"
+HOMEPAGE="https://github.com/tobgu/pyrsistent/ http://pypi.python.org/pypi/pyrsistent"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+       dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/hypothesis[${PYTHON_USEDEP}]
+               dev-python/pytest[${PYTHON_USEDEP}]
+       )"
+
+# https://github.com/tobgu/pyrsistent/issues/
+# fails
+#RESTRICT="test"
+
+python_test() {
+       export PYTHONPATH="${S}:${PYTHONPATH}"
+       py.test -v -v -x || die ${PYTHONPATH}
+}