dev-util/ccache: bump up to 3.7.6
authorSergei Trofimovich <slyfox@gentoo.org>
Mon, 18 Nov 2019 20:00:07 +0000 (20:00 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Mon, 18 Nov 2019 20:00:18 +0000 (20:00 +0000)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-util/ccache/Manifest
dev-util/ccache/ccache-3.7.6.ebuild [new file with mode: 0644]

index 80ed4d2087733cdb2f88a65d1819483afe423f3c..4e4b21678742359040deaaa9867326d7727ef566 100644 (file)
@@ -1,3 +1,4 @@
 DIST ccache-3.7.2.tar.xz 351168 BLAKE2B 6e5c8847f961bd5aa2cf325e582ece9e8bfb9c015fe3dcb01c8ca1e1834fdfb82a351ec49e203721486817df58c6aebf28e0af011f470fb739d5016f72191654 SHA512 3290f0609c27a2f063e632392be01ef163273115700f87a6d2954fcfd52fcc14bf66fc147ecbd2b692258317e113bf8be9f7efdf377560e2e8d9dd67cef58147
 DIST ccache-3.7.4.tar.xz 351576 BLAKE2B fa2a9c051ff3f9c0550c6301e8d6c9e0eb7ac68687a30a6e8c1ee794ecd6b62925fdc940d493a9fb22d9094c5f2a0f3b2788c6291430ca532661ea6ddef45456 SHA512 cc382f37f7efb30a64f6fc2b136ef7424fe51795a778dbb18dde7c9e80636515f242f51c3ef3231f74d154e65ed9e815abf8241eb1a8f4e0b4fe4f533ea27146
 DIST ccache-3.7.5.tar.xz 352440 BLAKE2B 6761d7a1a8c8086081fa46d50db1dce719856910da6324c9863a3f3731fdb0f5153e0d93a5c575074d1993650623e4e4b02d83dd3b656a31cb9be04ad6b58efa SHA512 d66eb9d923c3e4663242a034860bd198175e08274a295b6d5d94e6cd69fe32afa3fb8c228d64d5c5dda025e6f97d0aef0586ce4dbd66e8ce3a23093331f1841f
+DIST ccache-3.7.6.tar.xz 352692 BLAKE2B 97f6c3ea119b7f1f4fdab1dc88ac34a23bd8f893a1e399dd9f934b345ea27999b3750be6b474caf2bcaea77eb9281f99623312aa55dc5b5ffb7cf5e670b173f4 SHA512 c92a699b9761bbbde1666a9bc2718070a5beb24f7054d91226790c7903fe2e26a02d0782822bc811aaffcd88df3cd3e011a19061eb69569ed7140765cef8d6ba
diff --git a/dev-util/ccache/ccache-3.7.6.ebuild b/dev-util/ccache/ccache-3.7.6.ebuild
new file mode 100644 (file)
index 0000000..998d395
--- /dev/null
@@ -0,0 +1,88 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="fast compiler cache"
+HOMEPAGE="https://ccache.dev/"
+SRC_URI="https://github.com/ccache/ccache/releases/download/v${PV}/ccache-${PV}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+
+DEPEND="app-arch/xz-utils
+       sys-libs/zlib"
+RDEPEND="${DEPEND}
+       dev-util/shadowman
+       sys-apps/gentoo-functions"
+# clang-specific tests use it to compare objects for equality.
+# Let's pull in the dependency unconditionally.
+DEPEND+="
+       test? ( dev-libs/elfutils )"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-3.5-nvcc-test.patch
+)
+
+src_prepare() {
+       default
+
+       # make sure we always use system zlib
+       rm -rf src/zlib || die
+       sed \
+               -e "/^EPREFIX=/s:'':'${EPREFIX}':" \
+               "${FILESDIR}"/ccache-config-3 > ccache-config || die
+}
+
+src_compile() {
+       emake V=1
+}
+
+src_test() {
+       emake check V=1
+}
+
+src_install() {
+       DOCS=( doc/{AUTHORS,MANUAL,NEWS}.adoc CONTRIBUTING.md README.md )
+       default
+
+       dobin ccache-config
+       insinto /usr/share/shadowman/tools
+       newins - ccache <<<'/usr/lib/ccache/bin'
+
+       DOC_CONTENTS="
+To use ccache with **non-Portage** C compiling, add
+'${EPREFIX}/usr/lib/ccache/bin' to the beginning of your path, before
+'${EPREFIX}/usr/bin'. Portage will automatically take advantage of ccache with
+no additional steps.  If this is your first install of ccache, type
+something like this to set a maximum cache size of 2GB:\\n
+# ccache -M 2G\\n
+If you are upgrading from an older version than 3.x you should clear all of your caches like so:\\n
+# CCACHE_DIR='${CCACHE_DIR:-${PORTAGE_TMPDIR}/ccache}' ccache -C\\n
+ccache now supports sys-devel/clang and dev-lang/icc, too!"
+
+       readme.gentoo_create_doc
+}
+
+pkg_prerm() {
+       if [[ -z ${REPLACED_BY_VERSION} && ${ROOT:-/} == / ]] ; then
+               eselect compiler-shadow remove ccache
+       fi
+}
+
+pkg_postinst() {
+       if [[ ${ROOT:-/} == / ]]; then
+               eselect compiler-shadow update ccache
+       fi
+
+       # nuke broken symlinks from previous versions that shouldn't exist
+       rm -rf "${EROOT}"/usr/lib/ccache.backup || die
+
+       readme.gentoo_print_elog
+}